Possible SOLUTION ! for Black Screen UBUNTU and latest 460 driver!

I’m very new to Linux world, please forgive me. I fighted this for two days, no sleep and offer my solution for your judgment. Any comments are welcome.

All problems started 48 hours ago. Like many others I just did update (possible 460) or kernel or ubuntu… something got updated. After restart, black screen. I tried recovery mode, figure out that it is nvidia driver problem. Manage to load system running a comand line in recovery mode: sudo prime-select intel.

Loaded system and try everything, purge all nvidia, install different drives nothing helped. Black screen…

I gave up and installed Ubuntu 20.04 from scratch + 3rd party option selected. MY big surprise it did not work, loaded with black screen!!

One main thing that was constantly slowing me down and annoying is GRUB 2.04. It is slow, click takes seconds, most of time doubles keyboard keys clicks, have no idea when one click comes, hard to run recovery mode.

I install Ubuntu 20.04 again from scratch. This time normal with no updates and no 3rd party. Loaded nicely. Did update via Ubuntu + run this: sudo apt-get install ubuntu-restricted-extras - to get all the extras. Restart. All good.

This is possible solution now: I really hated GRUB. So after reading and testing a lot I added (remove #) this two option:

and removed “quite” to get:

This forced GRUB to stay in TEXT only mode and not load graphics! I propose that this was messing up the Nvidia loading drivers properly.

Next switched DVI cable to HDMI, I do not know why…

Next, went to ubuntu software update and selected 460 (proprietary, tested).

Reboot, what a surprise - loaded with no issues!!!

Please let me know if anyone having problems can change grub settings and check that it helps you too…

To change grub:
sudo gedit /etc/default/grub
(make changes as above suggested)
RUN: sudo update-grub

P.S. Discover timeshift by the way, I guess this is the way to go forward with updates? Any other suggestions how to avoid system changes? Do I stop updates? Kernel update?

1 Like

I am using GeForce RTX2070 Super as eGPU in Ubuntu 20.04. I’m facing same issue, same situation.
After sudo apt-get update; sudo apt-get upgrade; sudo shutdown -r now, OS is completely freeze and not even SSH available.

In my case, I was able to solve the issue as the following.

  • No re-installation ubuntu 20.04 was needed.

  • Unplug thunderbolt cable from eGPU box, reboot with internal HDMI port.

  • Uninstall all of nvidia drivers.
    sudo apt-get purge nvidia-* libnvidia-* xserver-xorg-video-nvidia-* (i don’t remember if cuda related packages were needed to be explicitly uninstalled…)
    sudo apt-get clean

  • Confirm cuda repo is configured in /etc/apt/sources.list.d/cuda.list
    otherwise get .deb file of cuda repo from here and install it. Index of /compute/cuda/repos/ubuntu1804/x86_64
    and then sudo apt-get update; sudo apt-get upgrade.

  • Plug in thunderbolt cable to eGPU and power on eGPU box.

  • Confirm nvidia driver is available by
    sudo ubuntu-drivers devices
    == /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/0000:02:01.0/0000:04:00.0/0000:05:01.0/0000:06:00.0 ==
    modalias : pci:v000010DEd00001E84sv000010DEsd0000139Fbc03sc00i00
    vendor : NVIDIA Corporation
    model : TU104 [GeForce RTX 2070 SUPER]
    driver : nvidia-driver-460-server - distro non-free
    driver : nvidia-driver-450-server - distro non-free
    driver : nvidia-driver-465 - distro non-free
    driver : nvidia-driver-460 - distro non-free recommended
    driver : xserver-xorg-video-nouveau - distro free builtin

  • Install ‘recommended’ nvidia drivers by
    sudo ubuntu-drivers autoinstall
    sudo egpu-switcher setup

  • Shutdown and connect HDMI cable to eGPU box, then boot OS.

Now it’s working. I am not sure what was root cause. Broken dependency in latest nvidia driver related package? or something else.

I’m sorry, I confirmed that DP was still not working even though after the above operation.
Maybe there is an issue around DP in latest driver.
HDMI is working.
Please forget my previous post.

i see the same thing on different environment.
All was working
opensuse tumblewed kernel 5.12.4
Lenovo X1 Extreme gen2
NVIDIA® GeForce® GTX 1650 Max-Q
NVIDIA Linux graphics driver, version 460.80
( Index of /opensuse/tumbleweed/x86_64 )
Lenovo USB-C Dock Gen2 with 2 external monitors
i insist on the fact that this has been working well a while.
Upgraded to latest patches in kernel 5.12.9 and now i cannot see the external screens

and i find this in journalctl :
systemd-udevd[745]: modprobe: ERROR: could not insert ‘nvidia’: Exec format error
kernel: nvidia: disagrees about version of symbol module_layout

My issue went away with kernel 5.12.10 - seems there was a compatibility issue with only 5.12.9 - my screens are back :-)

I noticed that ‘black screen’ on the Ubuntu always comes every after unattended-upgrade.
For example, my latest ‘black screen’ experience on a few days ago was just after
the following event (from /var/log/apt/history.log):

Start-Date: 2021-12-02 23:17:32
Commandline: /usr/bin/unattended-upgrade
Install: linux-modules-extra-5.11.0-41-generic:amd64 (5.11.0-41.45~20.04.1, automatic), linux-modules-5.11.0-41-generic:amd64 (5.11.0-41.45~20.04.1, automatic), linux-headers-5.11.0-41-generic:amd64 (5.11.0-41.4
5~20.04.1, automatic), linux-hwe-5.11-headers-5.11.0-41:amd64 (5.11.0-41.45~20.04.1, automatic), linux-image-5.11.0-41-generic:amd64 (5.11.0-41.45~20.04.1, automatic)
Upgrade: linux-headers-generic-hwe-20.04:amd64 (,, linux-image-generic-hwe-20.04:amd64 (,, linux-generic-hwe-20.04:amd64 (5
End-Date: 2021-12-02 23:17:57

So if somebody who faces same situation, please try to do the following manual update (Version number i.e. ‘nvidia-470’ and ‘5.11.0-41’ part must be changed accordingly) :

apt-get install linux-modules-nvidia-470-5.11.0-41-generic linux-signatures-nvidia-5.11.0-41-generic linux-objects-nvidia-470-5.11.0-41-generic

In my case, every ‘black screen’ events after unattended-update were resolved by the above command so far.