Black screen after updating of nvidia drivers

Hello everyone,

I use Kubuntu 20.04 and have GTX 1080 TI. I decided to update videocard drivers and after that I have an issue.
When I try to load the system I faced with black screen (without cursor). I tried to remove drivers and after that I could see all gui interfaces (but couldn’t use some features like nvenc). Then I have tried to reinstall nvidia drivers and again faced with black screen.
I have tried to install different versions of the drivers but always I saw black screen after that.
Every time when I removed drivers I could use my system. But then I have downloaded drivers from nvidia site, not from repository, and tried to install by .sh file. Now I see black screen and can’t remove the drivers by apt remove nvidia*.
Can someone help me with it?

Maybe it will help:

$ sudo modprobe nvidia -vv
modprobe: INFO: ../libkmod/libkmod-module.c:892 kmod_module_insert_module() Failed to insert module '/lib/modules/5.4.0-135-generic/updates/dkms/nvidia.ko': Operation not permitted
modprobe: ERROR: could not insert 'nvidia': Operation not permitted
$ xrandr --listproviders
Can't open display
lspci | grep "VGA"
26:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1)
$sudo systemctl enable nvidia
Failed to enable unit: Unit file nvidia.service does not exist.

I also tried to add nomodeset in grub but this is can’t help.

Please check secure boot status.

Sorry, what do you mean?

As I wrote earlier, I first installed drivers from the official repository, after which I encountered a black screen. After removing the drivers with apt purge nvidia* I was able to boot the operating system but only using nouveau. Only after several attempts to install drivers through the repository, I tried to install using the .run file downloaded from the nvidia site.
Now I tried to uninstall the driver using the same .run file, but I see an error: “There is no NVIDIA driver currently installed.” When I try to remove it with sudo apt purge nvidia* I get an error: “Unable to locate package nvidia.log Couldn’t find any package by glob ‘nvidia.log’”. However, when I try to install using ubuntu-drivers install I see a message that nvidia drivers 525 are already installed.

Please check secure boot status. in bios.

points to it, unsigned module.

1 Like

O my God! You are right! Secure boot was Enabled. I disabled it and now I can see my kubuntu with all interfaces. Thank you very much!
But I little nervous about this option. Does it somehow effect to my windows 10 which installed on the same PC?

Maybe Windows 10 will complain about it. If you’re nervous about it, reenable secure boot, then reinstall Ubuntu and during install choose to “install third-party software”. This way you should get a signed driver that will work with secure boot.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.