No matter which drivers I install, I cannot boot my ubuntu 20.04 LTS beyond a black screen with some stuff printed

I am new here, I hope I can explain my problem in the correct way.
Firstly I want to say that I know not too much about Graphic Cards and kernel.

I boot my OS(Ubuntu 20.04 LTS → kernel: 5.13.0-40-generic) using my processor(Intel(R) Core™ i7-10750H) as graphic manager.

If I change, using nvidia-settings, from intel to nvidia or on-demand, and using sudo mv /lib/modprobe.d/blacklist-nvidia.conf /lib/modprobe.d/blacklist-nvidia.conf.old and after digit sudo update-initramfs -u, trying to reboot the system, I got the following black screen

The content of /lib/modprobe.d/blacklist-nvidia.conf is the following.

blacklist nvidia
blacklist nvidia-drm
blacklist nvidia-modeset
alias nvidia off
alias nvidia-drm off
alias nvidia-modeset off

Instead If I use prime-select nvidia and keep the file /lib/modprobe.d/blacklist-nvidia.conf, I can boot inside the OS and view the graphic enviroment. I can use my graphic card, for example with tensorflow using the following trick.
sudo mv /lib/modprobe.d/blacklist-nvidia.conf /lib/modprobe.d/blacklist-nvidia.conf.old and after digit sudo update-initramfs -u do not reboot the system and digiting sudo nvidia-smi I can view the output

| NVIDIA-SMI 470.103.01   Driver Version: 470.103.01   CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   44C    P0    15W /  N/A |      0MiB /  3914MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|  No running processes found                                                 |

I don’t have any /etc/X11/xorg.conf file.

I attach also my
nvidia-bug-report.log.gz (122.0 KB)

This looks like the i915 driver loading too late.
Please add the lines
and run
sudo update-initramfs -u

then try switching to performance/on-demand mode again.

Unfortunately it doesn’t work.

If I use the technique you said and rebooting, I got the following.

and if I press esc button, I got the following.

If I boot in intel mode and then I try to digit nvidia-smi I got the last output of the following image.

Actually, the i915 I think that works fine alone, so if I use intel Driver I can boot the system and view the desktop, if I use nvidia driver I can not see anything.

Anything more that I can do? Thank you.

Please try removing “splash” from kernel cmdline.

As you said, I tried. It didn’t work.
I have tried without splash only and also a combination of the last two methodology you said.

When I tried to boot up the system I got the following.

The problem is when the nvidia driver is loaded, for some reason the intel gpu gets inaccessible

(EE) systemd-logind: failed to take device /dev/dri/card0: Device or resource busy

I don’t know what blocks it, though.