Getting black screen with Ubuntu 20.04.3 and kernel 5.11 with NVIDIA GTX1650 when NVIDIA drivers are installed

I am not experienced using NVIDIA and I have not been able to boot using a newly installed Ubuntu 20.04.3 with kernel version 5.11.

I am attaching here the bug report I got after installing nvidia-driver-470.
nvidia-bug-report.log (252.6 KB)

What finally worked was removing nomodeset from grub kernel parameters. I had it because my laptop would shut down randomly without it, because my nvidia driver installation was messy.

Started with a fresh install of Ubuntu 20.04, booted in with nomodeset . apt installed nvidia-utils-470. Rebooted into root shell from recovery. Verified driver installation with nvidia-smi . Removed nomodeset from grub. Rebooted.

Everything worked fine after this.

Thank you for your reply

Using tty2 console in recovery mode I ran
cat /etc/default/grub
and in GRUB_CMDLINE_LINUX_DEFAULT I only have “quiet splash” and no nomodeset. I had enabled that before but I removed it soon after.

Running apt install nvidia-utils-470 had no results as it was already installed
nvidia-smi does return a report with no processes found (meaning its installed) but I still can’t boot.

BTW, when I boot using nomodeset I get stuck with the following msg:
hdaudio hdaudioCOD2: Unable to bind the codec
Which I couldn’t fix.