NVIDIA Graphics Driver 535 problem booting Ubuntu 20.04

I am using Ubuntu 20.04 freshly installed and then installed graphics driver for RTX3090Ti GPU
sudo ubuntu-drivers install nvidia-driver-535
After installation and rebooting, the boot screen stuck with a black screen message:

/dev/nvme0n1p2: recovering journal
/dev/nvme0n1p2: clean , 14677/6102208 files, 9669612/244059136 blocks

Then I purged the driver and reinstalled with the command:
sudo ubuntu-drivers install nvidia:535
This time the boot is successful, but the network manager is gone. Maybe the kernel module for the network driver is not loaded.
Then I again installed nvidia-dkms-535 but no luck.

I have been severely suffering from nvidia driver issues with versions of 500 series. I tried back and forth but no luck.
The method sudo ubuntu-drivers install nvidia:535 gave me some hope but why the kernel modules are not handled thus network manager is gone?
Currently I am running with driver 470 but also set nomodeset on the GRUB to boot it properly.
Any solution would be really appreciated.

If you want to install the NVIDIA drivers as provided as part of the Distribution, it is highly recommended to use the “Software & Updates” interface and go through “Additional Drivers” instead of the command line you mentioned. It is less error prone.

If you want to use command line, then yo should rather use the official NVIDIA driver download.

But whatever you do, stick with one version, otherwise you will run into trouble on Ubuntu further down the line.


@MarkusHoHo I have also tried installing via “Software & Updates” interface. But still the problem persists. The only way I can get the system up is adding nomodeset after the “quiet splash” on the grub. But I heard adding nomodeset will run the GPU is reduced performance mode. When I install nvidia driver 470, it runs perfectly without “nomodeset”. But tried with nvidia driver 525, 535 etc but all them causing the same stuck issue. Same problem happens on my RTX3050 GPU as well as RTX3090Ti

/dev/nvme0n1p2: recovering journal
/dev/nvme0n1p2: clean , 14677/6102208 files, 9669612/244059136 blocks