Boot screen freeze with an underscore after installing nvidia drivers

I just brought MSI GL66 laptop (Intel and NVIDIA RTX 3060 GPU). I installed Ubuntu 20.04 the system boots fine. But when i install nvidia-driver-470 (have also tried 460) the system gets stuck on boot with a blank screen and a underscore sign.
I generated a nvidia bug report by enterein the tty. and then removed all nvidia drivers using sudo apt-get remove --purge ‘^nvidia-.’ and the system boots up again fine.

nvidia-bug-report.log.gz (361.2 KB)

Hope someone can help me solve this.
Thank you

It looks like you run Ubuntu 18.04…
Anyway your kernel is way too old for this new laptop.

[ 8.549682] [drm] Your graphics device 9a60 is not properly supported by the driver in this
kernel version. To force driver probe anyway, use i915.force_probe=9a60
module parameter or CONFIG_DRM_I915_FORCE_PROBE=9a60 configuration option,
or (recommended) check for kernel updates.

I tried updating the kernel by
sudo apt-get update
sudo apt-get dist-upgrade

Dosent seem to upgrade anything. Running uname --r to check the kernel version returns. 5.4.0-89-generic

How can I set CONFIG_DRM_I915_FORCE_PROBE=9a60 configuration option. I am new to ubuntu so dont really understand its file system.

If you are running Ubuntu 18.04, I think it’ll be difficult.
I strongly suggest you install 20.04 and use a HWE kernel.

Don’t try. It’s highly unlikely to work (it would be a kernel parameter to pass at boot time).

Ok previously i installed ubuntu 20.04 but the same problem seemed to persist so i downgraded to 18.04. Will reinstall 20 and post the new results from nvidia bug report.

Install an HWE kernel (package should be named something like this: linux-image-generic-hwe-XX.XX (XX.XX most likely is 20.04). And the according kernel headers (package linux-headers…). Then the nvidia driver. Then select your prime profile (i.e. sudo prime-select nvidia) and reboot.

Ok so i fresh installed ubuntu 20.04 then run an update and upgrade followed by linux-image-generic-hwe-20.04. and then install nvidia-driver-470 followed by prime select. I run into the same problem. Attaching the latest nvidi bug report. nvidia-bug-report.log.gz (400.5 KB)

After I purge nvidia drivers i can boot up fine.

The kernel version is 5.11.0-38-generic

So I follow the steps mentioned in No matter which drivers I install, I cannot boot my ubuntu 20.04 LTS beyond a black screen - #8 by youssefe.fares

The kernel parameters are gone, they’re just in an old logfile. Please

switch to nvidia (again): sudo prime-select nvidia
delete /lib/udev/rules.d/50-pm-nvidia.rules
remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
update the initrd (sudo update-initramfs -u)

For me There were no blacklist files. After purging all nvidia drivers from the tty. I was able to boot normally. Followed by sudo ubuntu-drivers autoinstall which installs the recommended drivers by itself. Next prime-select nvidia in root. and then a simple reboot fixed it for me.