Ubuntu 20.04 boots to black screen

I installed Ubuntu on a new machine (dual boot with Windows). It worked for a week, but now when I reboot into Ubuntu I receive a black screen after the grub selection.

Here is my
nvidia-bug-report.log.gz (106.7 KB)
. Below are system info and various commands I have run from various browsing other posts.

OS: Ubuntu 20.04.2 LTS
GPU: NVidia GeForce RTX 3080
Platform: Desktop

$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 4c8a (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 2206 (rev a1)

$ cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory

$ sudo prime-select nvidia
Info: the nvidia profile is already set

$ ls /lib/modprobe.d/
aliases.conf fbdev-blacklist.conf
blacklist_linux-hwe-5.8_5.8.0-59-generic.conf nvidia-graphics-drivers.conf
blacklist_linux-hwe-5.8_5.8.0-63-generic.conf systemd.conf

$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-5.8.0-63-generic
I: The initramfs will attempt to resume from /dev/nvme1n1p2
I: (UUID=05dc4948-285c-41a4-97cc-cd53f86ba57e)
I: Set the RESUME variable to override this.

$ sudo lshw -c video
*-display UNCLAIMED
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:63000000-63ffffff memory:50000000-5fffffff memory:60000000-61ffffff ioport:3000(size=128) memory:64000000-6407ffff
*-display UNCLAIMED
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 04
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: latency=0
resources: memory:62000000-62ffffff memory:40000000-4fffffff ioport:4000(size=64)

sudo rm /etc/X11/xorg.conf

sudo apt install nvidia-prime

sudo prime-select nvidia

sudo apt install nvidia-driver-455 (Driver version may be different than 455)

sudo modprobe nvidia

sudo nvidia-smi -pm 1

sudo apt install nvidia-cuda-toolkit

sudo apt install linux-headers-5.4.0-80* (5.4.0-80 is the kernel version, may be different)

sudo modprobe nvidia

sudo update-initramfs -u

These steps worked for me. It took me forever and I had to run these in recovery mode as that was all I could boot into.

Sorry, I had an extra modprobe command that was not needed.

3 Likes

Thank you very much for taking the time to post these instructions, I was able to get everything working with your help. I was missing these commands:
sudo modprobe nvidia
sudo nvidia-smi -pm 1

Additionally I had to Disable SecureBoot in the BIOS or the above commands would error out.

1 Like

Thanks @315jordan09 ! I had the same issue and your solution worked perfectly.

1 Like

this worked for me
mint 20 cinnamon
gtx 780
dual boot win10, mint, ubuntu
i used nvidia driver 460