Black screen after installing RTX 2080 Ti driver ubuntu18/19

Hi all! Could really use some help here, I’m unable to get my brand new Asus RTX 2080 Ti working with Ubuntu 18/19. After installing drivers, it always fails to boot and ends up with a black screen.

I’ve tried installing drivers in every possible way - through Ubuntu PPA, local .run file, installing from ‘Additional drivers’ software, etc. Always results in black screen on bootup.

I’ve tried Nvidia drivers versions - 410.5, 418, 435. All of them fail after reboot.

Has anyone got their RTX 2080 Ti working with Ubuntu?

CPU: AMD Threadripper 2920x
GPU: Asus TURBO-RTX2080TI-11G
Motherboard: Asus X399 STRIX e-gaming
RAM: Corsair 32GB

Can you switch to VT (e.g. ctrl+alt+f4)? If so, please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

If you have internet connection, you can use pastebinit to upload it from console.

  • install pastebinit (sudo apt install pastebinit)
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

For a quick check, make sure secure boot is disabled in bios.

I apologize for not posting the nvidia-bug-report earlier.

I’m unable to enter any kind of VT (tried F1,F2, etc,…)
so I switched to recovery mode and entered root line from there.

After following your instructions;

http://paste.ubuntu.com/p/JCdCrDwTsw/

Following this post I was able to get some output from nvidia-smi but again after reboot I get the black sreen and bootup fails-

https://devtalk.nvidia.com/default/topic/1062134/linux/installed-cuda-10-0-on-ubuntu-18-04-with-deb-file-nvidia-smi-quot-couldn-t-communicate-with-nvidia-driver-quot-/post/5378525/#5378525

FYI, I noticed that the graphics card fan spins up slightly faster when the black screen occurs during boot.

Unfortunately, the nvidia-bug-logs only contain info from the recovery mode start. Can you install and log in over ssh in the black screen case to create a new nvidia-bug-report.log?

So, I’ve managed to figure out what the problem was!

After searching through the forums for a while, I noticed multiple threads with people complaining about black screens and the issue for most of them was that they were using a DELL P-series 4k monitor.

So yeah, tried it with a different, 1080p monitor and it works like a charm.

But I want 4K, so I switched to running via display-port and now the DELL works fine as well!

So TLDR; The latest drivers can’t boot into 4K via HDMI, used DisplayPort instead.

Thanks for your quick response, @generix!

Ok, that’s really a known bug:
https://devtalk.nvidia.com/default/topic/1057195/linux/issues-with-430-x-series-4k-dell-monitor-screen-turns-off/post/5379094/

Cool cool