No matter which drivers I install, I cannot boot my ubuntu 20.04 LTS beyond a black screen

After installing nvidia drivers, my ubuntu boots to black screen or login screen that freezes.

I tried installing different driver versions. 440 and 390. I tried installing via the software & updates additional drivers GUI and with cmd via ppa.

I tried changing between gdm3 and lightdm.
I tried different grub args.

Attached bug report nvidia-bug-report.log.txt (84.5 KB)

Can only boot in safemode or with nomodeset and nvidia blacklisted.

My graphics card is GTX 1050 ti alongside an intel UHD card on an HP pavilion laptop. I tried prime-select with different args as well.I am dual booting with windows with secure boot disabled, legacy boot enabled.

I tried disabling wayland when using gdm3. I also tried deleting the x11 file mentioned on multiple support sites.

I have been stuck on this for a day and need nvidia to work get so that I can develop on two screens.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Attached (This is ran from safe mode, can’t access ubuntu otherwise)
nvidia-bug-report.log.txt (84.5 KB)

Also would like to note the lshw used to show my nvidia card but doesn’t anymore after a few purges and reinstalls.
Also additional drivers now says no additional drivers available.

Please

  • delete /usr/share/X11/xorg.conf.d/20-intel.conf
  • remove kernel parameters nomodeset and module_blacklist=nvidia
  • run: sudo prime-select nvidia
  • reboot
  • post the output of: grep 10de /lib/udev/rules.d/*

Hey, thanks for the prompt reply.
I am not sure where to remove the kernel parameters because I didn’t add them manually (Just checked my /etc/default/grub/), They may have been caused by the recovery mode boot? Any input there would be appreciated.
Meanwhile, I’ll try to boot into a text based login without the recovery mode.

Might be caused by recovery mode, if those are not set in /etc/default/grub/
Run sudo update-grub to make sure those are not some leftover.

Ran sudo update-grub and restarted. Logged in in text mode with alt+ctrl+f4 and generated some files.
nvidia-bug-report.log (785.2 KB)
A text search of the file shows nomodeset and module_blacklist=nvidia are still present. Not sure how the script works though, these might be old logs so over to you.
If they aren’t old, I think next step is to find the source of these kernel args.

The grep output requested output_text_login.txt (1.5 KB)

Also lshw shows that intel card is claimed
lshw -C video output (488 Bytes)

RE the blacklist thing, a grep on modprobe.d folder shows this file /lib/modprobe.d/blacklist-nvidia.conf
# Do not modify
# This file was generated by nvidia-prime
blacklist nvidia
blacklist nvidia-drm
blacklist nvidia-modeset
alias nvidia off
alias nvidia-drm off
alias nvidia-modeset off

Doesn’t look like it’s trying to make nvidia work.

The kernel parameters are gone, they’re just in an old logfile. Please

  • switch to nvidia (again): sudo prime-select nvidia
  • delete /lib/udev/rules.d/50-pm-nvidia.rules
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

Do I remove or keep this one?
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb

Yes, that’s needed. keep it.

initramfs says
I: The initramfs will attempt to resume from /dev/sda4
I: (UUID=c7193a1d-222b-435a-be2b-8afc007acdbf)
I: Set the RESUME variable to override this.

Anything we need to do about this?

No. it’s just an informational message.

It’s working!
Thank you a lot. I was about to purge and reinstall my entire OS. If this were reddit, I’d have definitely given you gold. Let me know if you have a patreon.

Can you explain like I am five what was going wrong?

You installed the “intel” driver package, which isn’t needed anyway and sets a fixed intel config. Common pitfall. Then there’s a bug with Ubuntu’s prime-select that sets a udev rule which removes the nvidia gpu completely and additionally sometimes forgets about the blacklist files.

Hello, i’m new here, first of all thank you for you time.

I’m having more or less the same problem as the described in this post.

I have a thinkpad laptop with a nvidia gtx 1050ti. I have installed the latest nvidia driver 450.66 and the latest kernel 5.4.0-45-generic.

I have two screens and when i attach both to my computer one of them it’s not working, always black screen.

If i try to change the configuration to enable the one it’s not working nothing happens.

I have run the nvidia-bug-report.sh in my computer, it’s attached to the post.

Thank you and best regards!.nvidia-bug-report.log.gz (482.7 KB)

P.S. I have read all the posts in the thread and followed all the steps described in generix responses.

I believe I am also experiencing the same problem; @BernalVarela I posted my issue in a new thread here.