Ubuntu 20.04 boot to black screen when selecting nvidia as prime after kernel update

Hello,
I’m using Ubuntu 20.04 LTS on my Thinkbook14+ with GeForce RTX 2050. Everything worked fine until the system performed an unattended-upgrade that upgraded the kernel from 5.14.0-1042-oem to 5.14.0-1044-oem:

Start-Date: 2022-07-01  07:23:27
Commandline: /usr/bin/unattended-upgrade
Install: linux-headers-5.14.0-1044-oem:amd64 (5.14.0-1044.49, automatic), linux-
image-5.14.0-1044-oem:amd64 (5.14.0-1044.49, automatic), linux-modules-5.14.0-10
44-oem:amd64 (5.14.0-1044.49, automatic), linux-oem-5.14-headers-5.14.0-1044:amd
64 (5.14.0-1044.49, automatic)
Upgrade: linux-oem-20.04:amd64 (5.14.0.1042.38, 5.14.0.1044.40), linux-headers-o
em-20.04:amd64 (5.14.0.1042.38, 5.14.0.1044.40), linux-image-oem-20.04:amd64 (5.
14.0.1042.38, 5.14.0.1044.40)
End-Date: 2022-07-01  07:23:55

After the upgrade, the system gives black screens when I reboot with Nvidia selected as prime (But that doesn’t happen when I switch the prime to Intel or on-demand).
I had been using the Nvidia driver 515.48.07 from Nvidia.com before I encountered the problem. I’ve tried:

  • Reinstall the driver
  • Upgrade the driver to 515.57
  • Using nvidia-driver-515 from PPA instead
  • Delete /etc/X11/xorg.conf
  • Roll back the kernel to 5.14.0-1042-oem

But none of them works.
Log file from recovery mode is attached. I would be really grateful if anyone can help.

(I’m not a native English speaker, so if there is anything unclear in my description, please don’t hesitate to ask.)

nvidia-bug-report.log (678.5 KB)

[   11.819395] intel_ish_ipc 0000:00:12.0: [ishtp-ish]: Timed out waiting for FW-initiated reset
[   11.825314] intel_ish_ipc 0000:00:12.0: ISH: hw start failed.

This triggers a 10sec delay in boot, maybe blacklist the driver or use an udev rule to remove the device.
The nvidia driver is not in the initrd so it loads too late. Please embed it into the initrd:
https://forums.developer.nvidia.com/t/linux-mint-nvidia-driver-loads-with-startx-but-not-on-initial-startup/168262/2?u=generix

Thanks for your reply! I tried embeding the nvidia driver into initrd and blacklisting the intel_ish_ipc. The system boots much faster, but unfortunately, it still gives black screen.
New report: nvidia-bug-report-2.log (962.2 KB)

Looks like you installed the nvidia driver from runfile. Rather uninstall it, install the driver fro m ubuntu repo and make sure the package nvidia-prime is installed.

Again, thanks for your reply.
The driver I am using now is installed from ubuntu PPA repo. (I used to use the driver from runfile before the issue, but I had already replaced it with the one from PPA after that.)