NVIDIA GTX 1650 and ASUS ROG Flow X13 with Ubuntu having display issues

Hello,

I purchased a ASUS ROG Flow X13 which comes with an NVIDIA GTX 1650. I need to install Ubuntu on this machine as its used for software engineering and machine learning with external GPU support.

I had installed Ubuntu 21.04 with the 5.11 Linux kernel. Installation went well and I saw my desktop, however, after installing recommended NVIDIA drivers for Linux (460.84) I noticed I was unable to access my GUI desktop. My only option was a TTY where I can login with username and password. I logged in and did nvidia-smi and noticed my GPU was detected, great! However, I am still unable to access my desktop and will appreciate your help.

I tried many things such as appending nomodeset to the kernel parameters, removing nomodeset after installing NVIDIA drivers. Additionally, I’ve tried different driver versions (430 and 440). NVIDIA did not seem to be black listed or disallowed so I am not sure what to do next. I am going to keep trying until I get it as I did see some others got past and were able to use this exact machine with Linux 5.11 kernel.

I am attaching my nvidia-bug-report.sh output to this message:

nvidia-bug-report.log

Thanks for your help in advance

I updated my Linux kernel to 5.13 using mainline and my desktop loaded with NVIDIA drivers. Issue is closed.

Update: after a few reboots without additional software any installations, the system went back into TTY mode although the kernel was upgraded. I am back to where I was before except this time I can at least get it to work for a while before the desktop mode goes away (repeatable steps below), I am suspecting a package update happened that may have caused this but not too sure.

Repeatable steps:

  1. Install Ubuntu 21.04
  2. Login and open terminal
  3. Run: sudo apt update
  4. Run: sudo apt upgrade -y
  5. Upgrade to Linux kernel version 5.13 (latest version at time of post) for amd64 using mainline
  6. Validate nomodeset is there after “quiet splash” in kernel parameters (/etc/default/grub)
  7. Run: sudo apt-add-repository ppa:graphics-drivers/ppa
  8. Run: sudo apt update
  9. Run: sudo apt install nvidia-driver-460
  10. Run: sudo apt autoremove && sudo apt clean
  11. Run: sudo reboot
  12. Validate you can login to Ubuntu desktop
  13. Run: nvidia-smi
  14. Run: uname -r # to validate kernel
  15. Touch screen and stylus pen even work, great

This is great until after a few reboots the computer goes into TTY as mentioned above. I did notice some got it running fine on Fedora using guidance from the ASUS Linux community, might try that next.