Geforce GTX 550 Ti does not work with Ubuntu 20.04

Hi
I’ve been trying to get my Geforce GTX 550 Ti working with the Ubuntu, but I cannot, so far I tried :

  • Download from nvidia the linux driver and disable Nouveau.
    With this, the pc hangs after login…, I checked another tty and I see the nvidia driver is
    being used, also set the nomodeset is added into grub.
    -After several attempts and looking into forums, I decided to reinstall .
    -Now with a clean install I selected the “sofware update” option “additional drivers” and selected 440, after reboot and also with and without nomodeset; still the driver does not load.
    I check nvidia-settings and still no nvidia driver is loaded, I looked into the nvidia debug logs and it shows a message that this board is supported by 390.xx legacy drivers
    and that 440 will ignore the GPU, but not sure why in the “ubuntu-drivers device” command shows as 440 the recommended driver.
  • Now I tried with driver 390 and it ask me to download the driver which basically got me in a loop now.

I dont want to keep messing with this and better ask the experts… can you suggest ?

  • Don’t use the .run installers, use --uninstall to uninstall them
  • install the drivers using Ubuntu’s Software&Updates application
    If this doesn’t resolve the issue, please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Hi
Sorry for the delay…
currently I didnt run any installer, I just used the one from Software&Updates application . still didnt work.
I attached the bug report, the file name is logs , but the original name was nvidia-bug-report.gz /
Thanks

logs.log (112.6 KB)
Here is the file.
thanks!

The driver is installed fine, just the on-board intel is interfering. Either disable it in bios or create /etc/X11/xorg.conf with contents:

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
    Option         "AllowEmptyInitialConfiguration"
EndSection

Hi Generix
I disable the interl card (set to pci-e) and this time at least it allowed me to login … but the resolution was bad… I checked the nvdidia-settings and no driver is loaded also I checked with lshw -c video and I dont see the driver … even though when I checked in the “sofware and udate” I see that the correct driver is selected… I took some printouts and the debug again … maybe you can help.
Also I did the config file for the xorg.conf and no improvement, later I did a nvidia-xconfig and still nothing … // any other suggestion ? logsMay19.log (240.1 KB) printout.log (2.7 KB)
THanks a lot for your help

You now have the 440 driver installed which is incompatible. Please switch back to the 390 driver using Ubuntu’s Software&Updates application.

Hi Generix
the driver is not install, I noticed that not the screen is stuck on the login (before I had it configure to login automatically)… so when I put the password it just hangs there…
I did a ctrl+alt+f2 and took some printouts again… I can see now that in lshw the driver is installed, but now I cannot login into the gui environment; any suggestion ? … I uploaded teh nvidia bug again… logsMay20.log (101.0 KB) printoutMay20.log (1.2 KB)
Thanks again for your again…
.

Hi Generix
I found the solution for the new issue, I added the “nomodeset” in the grub when the node is booting up… this allows me to login with the driver…then :
-modify the /etc/default/grub to add the nomodeset
-update-grub
but when the reboot is done still hangs at login… ; I have to do the nomodeset again during the booting process in order to login…
Any idea why the grub is not updating properly ?

The underlying problem is timing, the xserver is already starting up while the nvidia driver is still loading. Please re-create the initrd
sudo update-initramfs -u
and check if it then works properly.

Hi …
Actually not sure if it helped, it still hanged and I saw the grub showed the nomodeset but also noticed that the $vt_handoff is defined; so I removed it from /boot/grub/grub.conf and it seems that worked …
Thanks a lot !!