Ubuntu 20.04.5 boot now hangs on my PC with geforce gt 630

It happened 3 days ago, when I ran the routine software updates. Everything worked charmingly before that.
Next boot up and boom - the screen hangs over a black screen, with just a typed line on top stating " /dev/sda2: clean, xxxxxxxx/xxxxxxxxx files, xxxxxxxx/xxxxxxxxx blocks".
It also appeared before, but the system did not hang.

  1. Tried to load in safe-graphics mode, turn off nvidia-driver-390 and use nouveau driver first, then legacy nvidia-driver-340, to no avail, just a permanent alteration of resolution and bad typing.
  2. Adding nomodeset keyword to the grub files allowed for the boot to display the splash screen but it hangs nevertheless afterwards.
  3. This is where it get funniest: I tried to erase everything and install the more up-to-date LTS Ubuntu release, 22.04. The installation proceeded on badly distorted 800x600 graphics, managed to succeed (downloading updates from internet as well). But when trying to reboot the computer, it hangs again.
    So I tried to install the previous Ubuntu version, 20.04.5 without internet updates, thinking I’d get the vanilla nvidia drivers. It performs the installation, but it hangs on reboot, as previously.

The installations were done after formatting previous content, so from scratch, so logs would be those from a vanilla Ubuntu installation. This is an assembled desktop machine from 2014 with 8 processors i7-4770 @2.50 GHz, 16 GB RAM, nvidia Geforce Gt 630 GPU and a 25’’ MSI monitor.

I have tried again with a vanilla ubuntu 22.04 installation, did access the terminal with “run Ubuntu in advanced mode” and dloaded nvidia-driver-390.
Rebooted, then went on terminal again and tried “startx”: Xserver could not be loaded because of a fatal error with the GPU.
So using vi, I opened the log file at /var/log/Xorg.0.log and found a couple of errors. Transcriptions of the error lines are below:

[ 51.455] (EE) systemd-logind: failed to get session: PID 1088 does not belong to any known session
[many lines inbetween]
[ 75.125] (EE) Fatal server error: NVIDIA: A GPU exception occurred during x server initialization Please consult […] Server terminated with error (1). Closing log file

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

OK I got access to nvidia-bug-report.log. All this time I have been accessing my system in advanced recovery mode, so I don’t know how to export the gzipped file on a usb pen or on the internet.
I am writing the current post from a different Windows laptop.
Anyways, I have opened the log with vi and the file is huge. The first set of data is similar to the Xorg log file but goes more in detail about the fatal GPU error reported in the previous message. It states:

/usr/libexec/gdm-x-session[1394]: (II) NVIDIA: access.
(EE) NVIDIA(GPU-0): Failed to initialize DMA.
(EE) NVIDIA(0): Failed to allocate push buffer
(EE) Fatal server error:
(EE) AddScreen/ScreenInit failed for driver 0
(EE)
(EE) Please consult the The X.Org Foundation support …
(EE)
(EE) Server terminated with error (1). Closing log file.
(EE)

Quite a few lines above the previous, I found another error:

/usr/libexec/gdm-x-session[1394]: (WW) Falling back to old probe method for modesetting
(WW) Falling back to old probe method for fbdev
(II) Loading sub module “fbdevhw”
(II) LoadModule: “fbdevhw”
(II) Loading /usr/lib/xorg/modules/libfdevhw.so
(II) Module fbdevhw: vendor=“X.Org Foundation”
compiled for 1.21.1.3, module version= 0.0.2
ABI class: X.Org Video Driver, version 25.2
(EE) open /dev/fb0: No such file or directory
(II) modeset(G0): using drv /dev/dri/card0
(II) NVIDIA(0): Creating default Display subsection in Screen section

… and on and on it goes. I sincerely hope this is more clear now. If not, kindly direct me on how to extract the log.gz from the command line of a Linux recovery session (I can connect from there, just cannot use GUI only terminal).

Figured a way to extract the bug report gzipped file, here it is:
nvidia-bug-report.log.gz (89.6 KB)

You’re always getting an Xid 31 error on X start, I suspect the video memory or the gpu is broken.

Thank you @generix . Does this mean I have a hardware problem, i.e. the GPU is physically damaged? I wonder how this may be.

Yes, I think it’s damaged, being quite old. You could try reseating it in its pcie slot but I doubt this will help.

Yes, good call: after having taken out the GPU (annoying: it had a stripped screw) the system works perfectly.
If I may ask, what cheap 2gb/4gb max nvidia gpu shall I replace the old with on my 2014 PC? I don’t play videogames

Good question, difficult to get something on the low end, both nvidia or amd.
To have something recent, maybe a Quadro T400. There’s also the older GT1030, supprts only two monitors. Don’t take a GT730, those have only two years of driver support left.

In the end I went for a Nvidia T600.
Naturally, it could not have been this easy: Ubuntu 22.04 used to work fine with no video card, but once I plugged the T600 in, it cannot get past the initial boot, failing to display the splash screen.
The system however starts normally when adding nomodeset to the grub starter.
Moreover I have managed to install nvidia-drivers-520-open.
The new bug report:
nvidia-bug-report.log.gz (105.7 KB)

Thank you for your help.

Wrong driver. Please use Software&Updates to switch to the non “-open” driver version.

nvidia-driver-520 works perfectly and detects the video-card.
Hopefully you managed to solve all my problems now and we can close the thread with a big “thank you”.