Unix graphics fails on boot - Ubuntu 21.10

Hi to all!

After grub, linux starts to load normally until ending up on a black screen and completely locked. I have read hundreds of posts with this problem but I can not find a solution for my case. In fact, this post may be my last hope of fixing this issue.

It could work with nouveau but I need the CUDA cores pushing my computations.

I start by thanking you for any selfless help on this problem.

The configuration of my pc is the following:
HP Z6200 Workstation
24GB RAM
2xIntel Xeon E2620
2xNvidia Quadro K5000 in sli mode.
Ubuntu 21.10

I have done many tests with different distros:

  • Ubuntu 18, 21, 22
    -Fedora 35/36
  • Pop Os 22
    -Debian 9

I have not been able to boot x with neither the 390 nor the 470 driver series.

I only had partial success with Pop Os 22 and the 340 series of drivers, but of course without CUDA.

I always test the drivers compiled for these distros. The result is always the same, black screen.

Next, I try the method described at https://www.if-not-true-then-false.com/ for the cited distros. The result is always the same, black screen.

The common result in all the tests that I can guess is the following:

hpz620 kernel: nvidia-modeset: WARNING: GPU:0: Lost display notification (0:0x00000000); continuing.

Nouveau is well locked in all tests.

In Windows 10 the graphic configuration works perfectly, so I rule out a hardware failure.

I upload the logs of my last test to see if an awake mind finds the configuration problem.

Thank you very much.

The nvidia-bug-report of last test:

nvidia-bug-report.zip (132.2 KB)

And the nvidia-installer log:

nvidia-installer.zip (1.6 KB)

Does it work if you remove the second gpu for testing purpose?

No, I didn’t this test but today I test it and I got the same result, Black screen.

My next test will be update bios if has update available.

Can you see some kind of clue in the logs?

Thanks a lot.

PD: In nvidia-bug-report has many boots, some of this are from past night when I had plugged 2 k5000 yet.
reports-only-1-k5000.zip (155.2 KB)

I have not many hope about bios update due to I had installed the newest version already. In any case I reupdated it.

Hello!

All tests were unsuccessful.

I test with other Linux distributions without a good result.

The last test was in Manjaro 42.2. After installing nvidia-drivers-470xx-> Black Screen still!

I upload the nvidia-bug-report.log file. I don’t understand what causes this error :(

Sorry, I cannot upload the bug report.

We can download from this link:

https://1drv.ms/u/s!AiYVIzwbr49ig5I3q7a0nGlWwiOAiQ?e=HoqqL5

A system bios update wouldn’t help anyway, rather a vbios update for the nvidia gpus but that’s hard to come by.

nvidia-modeset: WARNING: GPU:0: Lost display notification (0:0x00000000); continuing.

is a dreaded error, the display engine crashed. The K5000 seems to have two DVI and two DP connectors, you seem to be using hdmi monitors on it. Which connectors are you using? Please check if any of those is triggering this by disconnecting them before booting.

Ok, I will test it.

Some tested things (maybe give a clue about this case):

I tried to update k5000 bios but was impossible. I tested with all methods and neverthing worked. Always I got “no compatible devices found”.

Then, I changed slot security for two x16 slots (from enabled to disabled) and I got 6 long bips, red light and don’t boot.

Update:

Now in Manjaro with nouveau, always when I’m logged starts with 1 display working. After 2/3 minutes, this screen start to blink and start the 2nd screen.

That’s really odd, nouveau’s display code is usually very reliable, much better than the nvidia prop. driver’s one.