Can't install Nvidia Driver on Ubuntu 20.4 without freezing on boot screen

I’ve a computer with 1 storage HDD, 1 HDD with Ubuntu, and 1 SSD with Windows. I’ve recently installed Ubuntu 2.10 on Ubuntu, but I have to edit Grub with “nomodeset” as per this tutorial, just to get to the login screen on initial install.

However, Ubuntu still won’t detect my second monitor. Whenever I try to install one of the Nvidia Drivers, Ubuntu will no longer load up. It’ll just get stuck at the loading screen (the black screen with the circular loading symbol, and I’ve had to re-install Ubuntu several times already.

I’ve tried Nvidia-driver-460 and 450, with my only other option being 390 (aside from the Server Options).

Also, for further context, I have an Nvidia GTX 970, with an ASUS Z170 Motherboard and Intel® Core™ i5-6600K CPU.nvidia-bug-report.log.gz (72.7 KB)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I have a visit-driver-460 installed without nomodeset and am attempting to boot up in Recovery Mode. However, it’s been on “[ ***] A start job is running for dev/disk/by-uuid/0633-6E8A (7s / 1 min 30s)” for about 20 minutes. There is not movement in the [ ***]. Is it stuck again, and if so, is there another way for me to run this command?

Please try booting with kernel parameter

It did not work. Unless I did it incorrectly. I added “pci=noaer” to the end of the linux line in grub for both regular and recovery mode, and still nothing. I re-installed Ubuntu (again) and reinstalled the 460 driver. I have not logged out yet. I will be attaching the report now.

You have secure boot enabled, please disable it in bios. Furthermore, drive sdd (32GB thumbdrive?) is broken, please remove it.

It is all working now. I’m not 100% sure what fixed it, but I am now using the nvidia-460 driver. I grabbed a new blank USB and re-imaged it with Ubuntu 2.04.2 using Rufus on Windows. This time I used the DD Image mode instead of the ISO image mode. Before installing the new Linux, I completely wiped the partition on that particular HDD. When installing, I created a new partition table and created only a root ext4 and swap space. I also did not opt to download Ubuntu updates initially, but that was just to save time (and I also unplugged any excessive USB devices like my PS5 remote, though I don’t think that would have had any effect). I did not have to use nomodeset to login initially, and the driver worked fine from the get-go. I’ve attached a final Bug Report in case there is anything I missed. nvidia-bug-report.log.gz (338.0 KB)