Ubuntu 20.04 screen freezes after ~5 minutes of uptime with Nvidia drivers?

I dual boot Ubuntu and Windows and am trying to use a dual-monitor setup, with a monitor being connected to a HDMI port in my laptop.

To use the second monitor, I am trying to use Nvidia’s proprietary drivers, since that is the only way my second monitor gets recognized.

Now, every time I install ANY Nvidia driver (tried 440, 435, 430, 390), through any means (Software & Updates -> Additional drivers; as well as manually - adding the graphics ppa repository) in Ubuntu, the system’s view completely freezes after a few minutes of being booted, requiring a hard-restart.

If any music is currently playing, it continues playing. I just cannot move my mouse or interact with the system, since the view of the system is completely frozen. This happens consistently after every boot.

The way I counteract this this is I boot up and quickly go to Software & Updates -> Additional drivers and revert back to default Nouveau graphics drivers. When reverted and rebooted, the system does not freeze anymore, but I cannot use my second monitor this way, because Nouveau does not seem to recognize the second monitor.

Also, I had to do “nomodeset” in GRUB settings, otherwise the system gets stuck on the login screen.

This used to happen with Ubuntu 18.04 as well, that is why upgraded to 20.04, thinking it might solve this problem.

System specs:
+Laptop: HP Zbook Studio G5 x360
+Video card: Nvidia Quadro P1000

I am looking for a way to get the second monitor working without the system freezing. I am not sure whether this is possible only with Nvidia drivers, or maybe there is some other way.

Any and all help is appreciated, since I’ve been stuck on this problem for quite some time. Also, please tell me if I can provide any more information about this issue.

Known bios issue of that notebook. Please use kernel parameter
intel_idle.max_cstate=1

It looks like this solution solved the issue - hadn’t had any freezes since applying this change. Thank you so much!

It seems the 440.100 introduced a driver-level workaround for this, once you get that version through Ubuntu updates you could try removing the parameter.

The fix with intel_idle.max_cstate=1 didn’t work on my notebook.

I have:

  • Asus X550JX
  • GEFORCE GTX 950M
  • driver 435

gdm3 freezes less than a minute after login. But, if I pick Plasma by KDE ‘flavor/ui-manager’ at login, it works just fine!

I’d like to go back to Ubuntu/Gnome because Plasma is very different and misses a lot of features I used in ubuntu