Upgrade Nvidia driver on windows, ubuntu won't boot

I have a computer with RTX 3080, which I dual boot Windows 10 and Ubuntu 20.04

I had nvidia-driver-460 installed on Ubuntu, which worked fine. Yesterday I updated the driver on Windows through GeForce Experience to 466, after this Ubuntu won’t boot. I didn’t change anything on Ubuntu.

I thought that drivers on Windows and Ubuntu are independent and should not affect one another.

I have tried upgrading the driver on Ubuntu, reinstalling, trying older drivers, but nothing works. Ubuntu only boots with nouveau , but it doesn’t detect my second display.

What can be the problem and what should I do to solve it?

If I uninstall Windows and reinstall Ubuntu only, would that solve the problem or did the driver change the graphics card itself?

EDIT: I have removed quiet splash from grub settings to try diagnose the problem, but it won’t even show any messages when using nvidia driver.

I have managed to get it working by installing nvidia-driver-460-server . I’m not sure whether it is working correctly, but I have both my monitors at correct resolution and nvidia-smi is working properly.

I have thought to install server driver because nvidia-smi was freezing the computer with normal driver even from root shell. So I thought to install just the server part to run my AI tasks, but surprisingly after installing server driver I managed to boot successfully.

I’m not sure what is the difference between normal and servers driver, but just happy to get it working at all.

I had a very similar issue, both using manjaro and then a few day later ubuntu. My guess there is a bug upstream, and it is affecting all operating system one by one. Most people that experienced this issues, didn’t do major updates. They restarted the PC and wasn’t working anymore.

If it is this same issue, it is related with displayport and high resolution displays. Are you using displayport? Did you try HDMI?