[Dual Boot] Alienware m17 r4 Nvidia 3070, Ubuntu won't boot, graphic drivers don't work

Hi everyone!

tl;dr: on my dual boot, i can’t boot Ubuntu via grub, with advanced boot options i can enter the OS but the nvidia drivers won’t work.

Its been a few weeks that i got my new machine, i always had a Alienware 17 r4 (1070) with dual boot running on ubuntu 20.04 LTS, so when i got this new one i promptly did the same and installed the dual boot.

The first issue was that the livecd (pendrive) would not show any image on the screen, but i could tell it was starting because of the noise, anyway when i restarted and re-entered the livecd with safe graphics, that way the image was there and i managed to install ubuntu normally.

After that i have some problems regarding the GPU drivers that i don’t really remember how i solved them, but after a while everything was working properly, nvidia-smi was displaying the GPU and i was being able to use the laptop normally.

After a few weeks, one day the pc stopped booting properly on ubuntu via grub, (windows still works fine), so the only way to access ubuntu was going into the advanced ubuntu settings, entering the safe mode on any kernel version and just straight resume the boot, that will take me to the login screen and the OS will boot, but the GPU won’t be recognized anymore, when i nvidia-smi it says it couldn’t reach the drivers

NVIDIA-SMI has failed because it couldnt communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I formatted the system a few times with different installation parameters, even now i have 21.04 installed, and the error is still the same.

Probably because i haven’t booted straight from grub, some graphical drivers won’t load, so any error message from inside ubuntu won’t be much relevant.

Can you guys help me out with that? I don’t want to be stuck working with windows anymore

If you boot normally, can you enter a virtual console and run nvidia-bug-report.sh as root? If so, upload the resulting file here.

Hi Mart, thank you for your response!

I did a map of the paths i can take here on boot, let me share:

  • 1 - Ubuntu (on grub) > Black screen (the only command that worked here was ctrl+alt+del, it reboots the machine)
  • 2 - Advanced options for Ubuntu > Ubuntu with Linux 5.11.0-37-generic > Black Screen (or Ubuntu with Linux 5.11.0-16-generi, resutl is the same)
  • 3 - Advanced options for Ubuntu > Ubuntu with Linux 5.11.0-37-generic (recovery mode) > Recovery menu > resume > Message saying that it will resume boot but some graphic drivers require a full graphical boot so those will fail to resume from recovery > Login screen
  • Pressing ESC on grub takes me to the grub bash command line.

The only place i see that i can get the bug-report is within the option 3, but it clearly states that the drivers won’t load properly, so i’m not sure it makes any sense.

I can format that drive and try re-installing any ubuntu version if needed, there were a few different screens that i got within different versions, what do you think i should try?

Thank you again!

Not sure if you answered my question…
If you boot into your option #1, can you switch to a virtual terminal with Ctrl+Alt+F1-6 (where 1-6 are the keys F1 to F6)?

Ok i managed to enter by installing the nvidia drivers (470) via recovery mode, by some reason with the default xorg drivers i was not being able to do so (maybe because of the 300hz monitor?).

Anyway, now i can generate the file, here it is.

nvidia-bug-report.log.gz (139.7 KB)

I just wonder, what is so difficult in answering a question directly… like in yes or no???


[ 0.000000] secureboot: Secure boot enabled

make sure nouveau and nvidiafb are blacklisted by checking the output of:
grep -r -E “nouveau|nvidiafb” /etc/modprobe.d/

Then sudo prime-select nvidia (if you want to drive on the nvidia GPU).
Reboot into BIOS.
Then disable secure boot in the BIOS.


Only nvidiafb was blacklisted, i added noveau to the list and disabled secure boot and it worked! Now i’m able to boot properly!

Thank you @Mart for your assistance! You are the grumpiest nicest helper i ever wished for!

Should i post something like a tutorial to close this topic?

Just mark my answer as solution.