Ubnuntu 20.04.5 failed to boot after driver installation on ASUS Vivobook15Pro with Geforce 3050 Laptap GPU

I was trying to setup the dual booting on my Vivobook15Pro with Geforce 3050 Laptap GPU.
Initially I have open-source driver from Xorg, and I switch to nvidia-driver-515 through “Sorftware and Updates”
Then my laptop failed to be booted. It wil stucked at balck screen with my text cursor blinking.
I follow the advices from the below links, but none of them solved my problems.
This morning I reinstall ubuntu, this time with Wifi so it install the nvidia-driver-515 automatically, so I don’t have to switch manually.
I tried to reboot a couple of times, it works, but after I install Anydesk, Chrome, VScode (just some common pkgs), it failed to boot again.

I try to follow the instruction, start my X, but it failed.
“If the machine can not be logged into remotely, please run the bug report script with X running.”
So I log from a remote terminal with startx -- -logverbose 6, but my X cannot be started from remote, too. So I log without it started.

Thank you for your time and consideration.

nvidia-bug-report.log.gz (284.9 KB)

My xserver log.
Xorg.0.log (9.0 KB)

The advice links I followed, I also have set nomodeset in the grub.

Also, I find out I was missing nvidia-dkm-515, but after I installed it, it did not solve the issue.

Please remove nomodeset parameter if you have set it, then try this:

1 Like

I have folowed your instructions,

  1. I removed nomodeset and sudo update-grub2
  2. I have added the lines:
    and run
    sudo update-initramfs -u

it still stuck in blank screen, but this time was able to startx -- -logverbose 6 from tty
Here is the newest bug report.
Thank you for your advices.
nvidia-bug-report.log.gz (317.1 KB)

Now the i915 driver loads too late, please also add it to the initrd by adding the line
to /etc/initramfs-tools/modules and running sudo update-initramfs -u

It worked like a charm.
But my speaker now has no sound, while BlueTooth earphone works.
I have checked the pavucontrol, the speaker is outputting.
I have tried to reinstal pavucontrol and alasa tool.
It did not work.
Also, I have tried the solution in the link
I am not sure whether I was allowed to ask this kind of question here.
But are there others also run into this problem after the graphics fix?
If you need the report, let me know,
Thanks for your help.

Please attach a dmesg output.

log.txt (94.1 KB)
Thank you for your patience.

It’s a Realtek ALC294 sound chip which seems to be problematic with Linux. Please check if any of these help:

In general, to get an updated sound driver you might want to upgrade your kernel using the liquorix ppa.

Upgrading the kernel using liquorix ppa did not work for me.
My kernel is now Linux 5.19.0-7.1-liquorix-amd64
I have also tried to follow the links:
follow the below

to add the following into etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=asus-zenbook

Also, I tried the script method, but it only works for a couple of minutes and suddenly I am deaf again.


I’ll try to look up other solutions.

From looking around, this seems to be a crappy sound chip. I guess your best shot is attaching to the kernel bugzilla entry, seems some people are putting effort into it and are about to contact realtek devs about it.

1 Like

I think I’ll look around for the solution on related forums.
Thanks for your timely help with my graphics!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.