Ubuntu 22.04.1 LTS - GeForce RTX 3050 Ti Mobile

Hi all,
I just got my new Dell XPS 15 - 9520 with GeForce RTX 3050 Ti Mobile. I have install Ubuntu 22.04.1 LTS and after that i have follow this guid as my screen was frozen ([Solved] Ubuntu Freezing at Boot Screen [Screenshot Guide]).

So, after i fix that problem im trying now to install this “nvidia-driver-515” drivers. After i install them via terminal iv got the black screen problem.

I try downgrade to 510 and 470, but same results. Black screen “startx” wont start and i remove them and got back the screen. I try installing them via GUI from the Additional Drivers but still same results after reboot.

Can someone tell me what im doing wrong and how to properly install the drivers so i can use the card? I read all possible blogs try some stuff but still without success.
Some output:

00:02.0 VGA compatible controller: Intel Corporation Alder Lake-P Integrated Graphics Controller (rev 0c)
01:00.0 3D controller: NVIDIA Corporation GA107M [GeForce RTX 3050 Ti Mobile] (rev a1)

$uname -r

1 Like

If you booted with nomodeset, this is expected. This is only a temporary troubleshooting option to fix the real cause.
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Where can i find this nvidia-bug-report.sh ? Do i need to install the driver first ?
Or what kind of report do you need ?

Also, should i remove “nomodeset” from grub ?

nvidia-bug-report.sh is included with the driver packages. You could run it before rebooting so I can get a first info from your system.

Strangely, when i run it first time it kicks me out of the GUI, put me in the terminal.
I have install the 515 drivers, run the bug report and here is the results. ( I have to run twice as the first time kicks me than i run it again).
backup-nvidia-bug-report.log.gz (279.8 KB)

Let me know if anything else is needed.
Any suggestions how we can fix this ?

You might need a newer kernel for your 12th gen intel igpu. Please use the liquorix ppa to upgrade it, then try removing “nomodeset” and check if it works.

Hi thanks for the answer, but can you pleas guide me more in details on the kernel part. How to install it - “use liquorix ppa” ?


Nothing has changed. Same problem. I install the liquorix kernel fallowing the steps from your suggestion and from the liquorix .net/#install - after that i reboot it than i install the 515, remove the nomodeset and reboot again. Same, no GUI. I run the script, here is the logs

new-nvidia-bug-report.log.gz (260.1 KB)

Now I would need a log from a boot without nomodeset to find the deeper cause.

I use “journalctl -b” to generate the boot log hope is this what you need?
And yes i have removed the nomodeset from it.
Also from the logs (nvidia logs) i notice this ERROR but im not sure if its related

ERROR: Kernel configuration is invalid.“;
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.”;
echo >&2 " Run ‘make oldconfig && make prepare’ on kernel src to fix it.";

boot.log (980.0 KB)

The error is always displayed, just ignore.
The boot.log was from a boot with nomodeset.
sudo journalctl -b-1
to get the log from the previous boot (-2 for the boot before the previous…)

I need to create two post as i can’t upload 2 files.
Strange regarding the nomodeset as i have remove it from grub file ill check again.
boot-1.log (417.7 KB)

That’s still with nomodeset. You can see it on top of the log file
Command line: BOOT_IMAGE=/boot/vmlinuz-5.19.0-14.1-liquorix-amd64 root=/dev/mapper/vgubuntu-root ro quiet splash nomodeset vt.handoff=7

I just restart and this is the logs … but i have not install the drivers as i can’t access the gui
should i install the drivers and restart and upload the boot log or its not needed in that way ?
new-boot.log (576.4 KB)

I just install the drivers and everything is ok now i guess ?
I got the gui up. Is there a way to check if everything is fine ?
nvidia-new-boot.log (501.6 KB)

But seams like its still not working

I don’t know which state you’re in now. The cross-post on PM confused me.
The nvidia gpu is in offload mode now which is the default mode.
To run something on it, e.g. glxgears:
Use prime-select to switch modes.

Why do i have two display modes
Wayland and X11 ?
Which one to use and how to delete the other one ?
Also, how can i check if my Graphic card is working now ?

Currently im seeing that the driver is installed but i still cant see if its working properly. Is there a way to test it ?