Ubuntu 20.04 - init i915 and HDMI codec failed

Continuing the discussion from Ubuntu 20.04 No Sound:

@generix Sorry for creating another topic, but the forum doesn’t allow me to reply again the other one. So, I could load the recovery mode, as u asked.

Ok, I’m really puzzled what’s going on with your hardware. Since this is an Optimus notebook, the intel gpu has to work correctly, the nvidia gpu just being secondary.
Please uninstall the nvidia driver to be sure it doesn’t interfere and run a system update so you should get a newer kernel (you’re running -29, current should be -31 or -33). Then check if you can boot using just the intel gpu.
Otherwise, I would recommend a complete reinstall leaving the nvidia driver out and check if the intel gpu works properly.

So, I reinstalled the system without the proprietary drivers; still not able to boot without nomodeset. Then i followed your earlier advices, upgraded the system, tried to install i915 driver and this time it was really missing, so the installation worked. However, still not able to boot without nomodeset. I checked again and i915 is installed and not blacklisted.

Perhaps I should say that sometimes when booting i used to receive a message “Firmware Bug: failed to parse event in TPM final events log”. I managed to disable the TPM and also the PTT, but still not able to boot. I did the installation when TPM and PTT was enable, don’t know if this may have caused some issue, what do you think? Also, could I try going back to 18.04 LTS, since it’s more consolidated

The TPM issue can cause a kernel panics depending on kernel version, better leave it disabled for now. It shouldn’t have an influence on the grphics problem, though.
The intel gpu is a pretty much standard UHD 630, nothing special should be needed to get it working. I’m rather fearing the gpu is broken, only working in basic vga mode. The other possibility would be a kernel regression, so you should really check if it works with Ubuntu 18.04, your notebook model was certified to work with that, at kernel 4.15.

In case Ubuntu 18.04 with the 4.15 kernel also doesn’t work, you could try doing a mainboard reset:

  • remove battery
  • remove power adapter
  • press and hold power button for 20 seconds
  • attach power adapter
  • boot
1 Like

I’ll try later. I should say that I’m working with a dual boot, and Win10 is working pretty good. I bought this machine 4 months ago only and decided to do the dual boot now because due to the pandemy i won’t have access to the university pc, and I need Linux to work with bioinformatics. So, it shouldn’t be a hardware issue, or am i wrong?

It shouldn’t be a hardware issue then. To make sure, check Windows’ device manager, graphics adapters. If it says Intel UHD 630, hw should be allright, if it says ‘standard vga adapter’ or ‘Microsoft basic display adapter’ then it’s broken.

Guess it shouldn’t be better

Looks fine.

So, 18.04 should work. Probably some kind of compatibility issue, I’ll install it later and 'll let you know if worked.

Alright, now it’s working. With proprietary drivers and no nomodeset, however no sound hahaha only dummy output. I’ll try some solutions from internet now.

Tried the solutions here and still no sound, despite now my headphones and sound device appear in audio settings. By the way, I’m running last version of kernel, so the previous problem probably wasn’t with it.

Must be something specific to 20.04 then. Please create a new nvidia-bug-report.log.

Here nvidia-bug-report.log (1.3 MB)

I ran pulseaudio -k && sudo alsa force-reload and now the return in pacmd list-cards is different than before, take a look:

poccia@Poccia-G3-3590-Ubuntu:~$ pacmd list-cards
2 card(s) available.
index: 0
name: <alsa_card.pci-0000_01_00.1>
driver: <module-alsa-card.c>
owner module: 7
properties:
alsa.card = “1”
alsa.card_name = “HDA NVidia”
alsa.long_card_name = “HDA NVidia at 0xa3080000 irq 17”
alsa.driver_name = “snd_hda_intel”
device.bus_path = “pci-0000:01:00.1”
sysfs.path = “/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1”
device.bus = “pci”
device.vendor.id = “10de”
device.vendor.name = “NVIDIA Corporation”
device.product.id = “10fa”
device.string = “1”
device.description = “HDA NVidia”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-pci”
profiles:
output:hdmi-stereo: Saída de Digital Stereo (HDMI) (priority 5400, available: no)
output:hdmi-surround: Saída de Digital Surround 5.1 (HDMI) (priority 300, available: no)
output:hdmi-surround71: Saída de Digital Surround 7.1 (HDMI) (priority 300, available: no)
off: Desligado (priority 0, available: unknown)
active profile:
ports:
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
properties:
device.icon_name = “video-display”
index: 1
name: <alsa_card.pci-0000_00_1f.3>
driver: <module-alsa-card.c>
owner module: 8
properties:
alsa.card = “0”
alsa.card_name = “HDA Intel PCH”
alsa.long_card_name = “HDA Intel PCH at 0xa5518000 irq 140”
alsa.driver_name = “snd_hda_intel”
device.bus_path = “pci-0000:00:1f.3”
sysfs.path = “/devices/pci0000:00/0000:00:1f.3/sound/card0”
device.bus = “pci”
device.vendor.id = “8086”
device.vendor.name = “Intel Corporation”
device.product.id = “a348”
device.form_factor = “internal”
device.string = “0”
device.description = “Áudio interno”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-pci”
profiles:
input:analog-stereo: Entrada de Estéreo analógico (priority 60, available: unknown)
output:analog-stereo: Saída de Estéreo analógico (priority 6000, available: unknown)
output:analog-stereo+input:analog-stereo: Duplex estéreo analógico (priority 6060, available: unknown)
output:hdmi-stereo: Saída de Digital Stereo (HDMI) (priority 5400, available: unknown)
output:hdmi-stereo+input:analog-stereo: Saída de Digital Stereo (HDMI) + Entrada de Estéreo analógico (priority 5460, available: unknown)
off: Desligado (priority 0, available: unknown)
active profile: output:analog-stereo+input:analog-stereo
sinks:
alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Áudio interno Estéreo analógico
sources:
alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Áudio interno Estéreo analógico
alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Áudio interno Estéreo analógico
ports:
analog-input: Entrada analógica (priority 10000, latency offset 0 usec, available: unknown)
properties:
analog-output-speaker: Alto-falantes (priority 10000, latency offset 0 usec, available: no)
properties:
device.icon_name = “audio-speakers”
analog-output-headphones: Fones de ouvidos (priority 9000, latency offset 0 usec, available: yes)
properties:
device.icon_name = “audio-headphones”
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: unknown)
properties:
device.icon_name = “video-display”

The log showed the sound cards and outputs working, there just isn’t anything connected to it. What did you connect to hdmi?

Actually nothing, i only have a headphone on p2 and the PC loudspeaker and no sound from both

Then this has nothing to do with the nvidia hardware, it’s only providing hdmi audio. You’re having problems with the standard intel audio. Looking at the logs, it looks like this:
https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/689444

I found out that linux isn’t recognizing my audio controler (Realtek ALC3254). It sees only NVidia device. However, I didn’t find a solution yet.

Edit: I tried to boot a older kernel version, 5.3.0-28, and worked partially, now it recognizes my internal speakers, but not my internal microphones. On pavucontrol the microphones are available, but “unplugged”. When I plug a headphone the internal microphones become puggled, but if I select it, then the headphone became mute. Found out that many people has the same problem with this Dell model and other pcs, but none solution yet.

Hey @generix sorry for bothering you, but I found here https://certification.ubuntu.com/hardware/201906-27107 that my model was certified with 18.04 (I already have) and 5.0.0-1017-oem-osp1 kernel , but I have no idea how to install this version, I believe is a custom version. Do you have some advice?