Ubuntu 20.04 does not boot after installing Nvidia driver

My system:
GPU: RTX 2080 Super
Dual boot (both legacy) with Ubuntu 18.04 on one SSD and Ubuntu 20.04 on another SSD.
Ubuntu 18.04 has nvidia driver 460 installed and is booting - this is not the problem in this case.
Ubuntu 20.04.6 fresh install, kernel version 5.15 - this is the OS where the problem occurs.

What have I tried:
I have tried installing drivers 525, 515, 510, 470, 460 (ends up installing seemingly 470) and none of them boot.
I have used different command line installation methods (apt, ubuntu-drivers, then this manual here - NvidiaDriversInstallation - Community Help Wiki), each time fully uninstalling the previous drivers before trying again from scratch.
I have tried to boot also to recovery mode, no success. I also tried different grub edit options with nomodeset and some others, no success. Ubuntu hangs on boot and does not finish.
The only way to recover from not booting is to boot to the previous kernel from the grub menu (for example to… instead of…) where the nvidia drivers were not installed, then fully remove the nvidia drivers (sudo apt remove --purge …), and then reboot, resulting in using Ubuntu nuoveau drivers again. But nvidia drivers are vital for this system.
I have also noticed that the driver 525 sometimes boots but does not communicate with the driver (nvidia-smi output says no device found). And sometimes does not boot also.
I have also tried to install the recent production driver 530 but the result is the same - booted once but then no comm with the driver, and after that other attempts end up not booting. One installation walkthrough also attached.

What I have not done:

  • I have not installed nvidia drivers using nvidia runfile installers.
  • I have not used any open source nvidia drivers (nvidia-driver-xxx-open).
  • I have not tried to convert from legacy boot to uefi. Does it even make sense or is worth the possible effort? Nvidia technical explanation here would be helpful because I have not found such clear info online that uefi boot mode is needed for nvidia drivers to work. (Also need to consider that the old Ubuntu 18.04 needs to be healthy and ready to run without big delays, like backup recovery or fixing broken boot. And dual boot OS-s need to be in the same boot mode, to avoid unnecessary problems.)


  • one walkthrough of the latest 530 driver install attempt.
  • nvidia debug report (collected while booted with the previous kernel).

What could be the root cause and what to do to get it work?

nvidia-bug-report.log.gz (118.0 KB)
journalctl_output.txt (20.3 MB)
walkthrough_nvidia_driver_530_install_and_remove.txt (49.4 KB)

Neousys board

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.