Nvidia driver for rtx 4060 ti 16gb in ubuntu

I recently purchased a desktop. The CPU of the computer is i5-12400, and the GPU is RTX 4060 ti 16GB. I installed Ubuntu 22.04 on the desktop with this configuration. I tried both manually installing Nvidia driver version 535 and installing it automatically. However, it didn’t respond when I entered the ‘nvidia-smi’ command. Is there a more appropriate version of the Nvidia driver available? Or could there be a problem with the system configuration or the installation process? The only additional step I took during the installation process was modifying the kernel booting line in grub to restrict the use of the CPU’s integrated graphics.

reference: Manual "nomodeset" Kernel Boot Line Option for Linux Booting | Dell 대한민국

Hello there - I’m working on a similar problem with a 4060 ti.

Can you post the error message from your “nvidia-smi” command ?
Do you know if you have UEFI secure boot enabled ? If the error message complains about no kernel loaded, then you probably have to learn how to generate UEFI signing keys and sign the kernel.

If it’s saying “no devices found” that’s the same problem I’m struggling with.


Hello! I apologize for the delayed response due to solving the issue. In my case, I was able to resolve the problem. There were two issues that I identified: conflicts between the integrated and external graphics cards, and Ubuntu not recognizing the graphics card. I will provide you with the methods I tried to resolve this, which may be helpful for your reference. It may be challenging to refer to as it is written in a different language. I hope referring to the attached link can assist you in resolving the issue. Thank you.

1 Like