VIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running

After upgrading Ubuntu packages and firmware, the nvidia driver stopped working. When trying nvidia-smi I got the error message “VIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

Bug report is attached, can you help me identify what the problem is - and how to solve it?

nvidia-bug-report.log.gz (93.0 KB)

Have you re-booted?
Have you checked the driver is installed and running?

Run the following command:

nvidia-settings -q NvidiaDriverVersion


cat /proc/driver/nvidia/version

In the logs I can see that the driver is not loaded:

mars 07 18:32:09 x1-ext-g5 nvidia-settings-autostart.desktop[3352]: ERROR: NVIDIA driver is not loaded

Even if you run the nvidia-settings command above it will report the driver is not loaded like the following:

nvidia-settings -q all:

ERROR: NVIDIA driver is not loaded

Further down the logs:

*** /proc/driver/nvidia/./version does not exist


*** /proc/driver/nvidia/./params does not exist


*** /proc/driver/nvidia/./registry does not exist

Everything here is pointing to the driver actually not loading, or installed properly, how was the driver installed? What version of Ubuntu are you running?

Run the command:

ubuntu-drivers devices

It should list available drivers for you, then run the following command sudo apt install nvidia-driver-xxx where xxx is the “recommended” version.

You have to ensure you reboot the system after the install

1 Like

Thanks for the reply, with the suggested commands!

To answer your questions first:

  1. Yes, I have rebooted several times (after every change I’ve made)
  2. I am running Ubuntu 22.04.2 LTS
  3. I had installed the recommended driver using the “Additional Drivers” tab of Ubuntu’s “Software & Updates”

Output of ubuntu-drivers devices:

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd000025A0sv000017AAsd000022F8bc03sc00i00
vendor   : NVIDIA Corporation
model    : GA107M [GeForce RTX 3050 Ti Mobile]
driver   : nvidia-driver-525-open - distro non-free recommended
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-515-open - distro non-free
driver   : nvidia-driver-510 - distro non-free
driver   : nvidia-driver-470 - distro non-free
driver   : nvidia-driver-525 - distro non-free
driver   : nvidia-driver-525-server - distro non-free
driver   : nvidia-driver-515 - distro non-free
driver   : nvidia-driver-515-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

== /sys/devices/virtual/dmi/id ==
modalias : dmi:bvnLENOVO:bvrN3JET30W(1.14):bd01/03/2023:br1.14:efr1.9:svnLENOVO:pn21DECTO1WW:pvrThinkPadX1ExtremeGen5:rvnLENOVO:rn21DECTO1WW:rvrSDK0T76461WIN:cvnLENOVO:ct10:cvrNone:skuLENOVO_MT_21DE_BU_Think_FM_ThinkPadX1ExtremeGen5:
vendor   : Lenovo
model    : product_version
driver   : oem-sutton-balin-meta - third-party free

You were 100% correct about the output of the commands, so I now tried sudo apt install nvidia-driver-525 and while it gave some error output (Error! Module version 525.85.05 for nvidia.ko is not newer than what is already found in kernel 5.19.0-35-generic (525.85.05).) it completed successfully.

And as I was writing this reply (before rebooting), the external monitor suddenly connected to USB-C!

So then I ran the suggested commands again:```
$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 525.85.05 Sat Jan 14 00:49:50 UTC 2023
GCC version: gcc version 11.3.0 (Ubuntu 11.3.0-1ubuntu1~22.04)

$ nvidia-settings -q NvidiaDriverVersion

Attribute ‘NvidiaDriverVersion’ ([gpu:0]): 525.85.05

So it seems to have loaded dynamically as I was typing.
I'll still try a reboot - but it seems to be working now.
Thanks a lot for your very valuable input!
1 Like

So, in short, sudo apt install nvidia-driver-525 solved the problem!

I had installed the driver through the Ubuntu GUI previously, but seems everything was not included.

Thank you so much for your detailed response that helped me solve my problem!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.