Ubuntu 18.04 Doesn't Use My GPU(GTX 1650)

Hello there!
I am new at this forum so I apologize if I do anything wrong. My ubuntu shows llvmpipe (LLVM 10.0.0, 128 bits) as currently used graphics and doesn’t recognize my graphics card. Also I cant use “nvidia-smi” command it gives “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.” error. I tried almost everything I saw on this and other forums so I am in need of any advice.
I am using nvidia driver 470 and kernel 5.15

Also I have “quick splash nomodeset” in my grub files because I can’t launch without adding it.

This is the output of “lshw -C display”

  *-display UNCLAIMED       
       description: VGA compatible controller
       product: TU117M [GeForce GTX 1650 Mobile / Max-Q]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: memory:fb000000-fbffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:e000(size=128) memory:fc000000-fc07ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Cezanne
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:04:00.0
       version: c5
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:d000(size=256) memory:fc500000-fc57ffff

This is the output of " lspci -k | grep -EA2 'VGA|3D"

01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device 150c
	Kernel modules: nvidiafb, nouveau
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne (rev c5)
	Subsystem: ASUSTeK Computer Inc. Device 150c
	Kernel modules: amdgpu

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Here it is
nvidia-bug-report.log.gz (81.5 KB)

Incompatible kernel, please use the liquorix ppa to upgrade.
Please remove “nomodeset” kernel parameter.
Please manually upgrade firmware https://packages.ubuntu.com/en/jammy-updates/linux-firmware

1 Like

I can’t open Ubuntu once I remove nomodeset. It stucks in black screen after setting up wifi-bluetooth card. Does upgrading firmware manually solve this?

Probably. The panel is driven by the amd gpu which needs recent firmware to work.

I opened the downloaded xz file and installed it via “tar -xvf” it has put a file in download directory. Also I removed nomodeset from “quiet splash nomodeset” so it is just “quiet splash” now. What is next? (I also did “sudo update grub”)

Don’t extract, install, Double-click or apt or dpkg.

It says No ‘:’ in the uri when I doubleclick it. But also it has created a file with lock sign on it which is named “linux-firmware_20220329.git681281e4”

I put the firmware file in /lib/firmware and than did “sudo apt-get update”.

I also did the liquorix ppa thing but when I tried to use liquorix kernel it locked me out completely. There is just black screen and error “unable to read RDB block 8” but after like 3 seconds I can hear the sound of ubuntu opening. Please help I need to get this issue solved by the end of the week :(

Please learn how to install packages. Download the firmware.deb, then run sudo -i in its directory.

Is the package that you are talking about “linux-firmware (20220329.git681281e4-0ubuntu3.5.debian.tar.xz”? Because I can’t install it with doublee-clicking. Sorry for all the trouble I am causing but I am a complete beginner in Ubuntu :(

No. That’s the source package. in “Download linux-firmware” click on “all” then on a mirror. then try just double-cliciking it .

Okey I have downloaded and installed .deb file. What to do now? (I have also installed liquorix kernel)

install it?

I miss told sorry :) I’ve added the repository for it and then updated. I googled it and this were told to do in one website.

Ok, I misread. Please delete any xorg.conf in case you crated one, then reboot.

I haven’t created any but there is only one xorg.conf file in the system, it is in “/usr/share/doc” and it is named “xserver-xorg-video-intel-18.04”. Should I delete it too?