ubuntu 18.04 still uses llvmpipe driver

I have an ubuntu 18.04 computer with a nvidia gtx1080ti card. I’ve installed 430.40 driver on it, but for some reason, the driver isn’t being used (llvmpipe is used instead). Below is the output of the terminal:
$ nvidia-smi
Mon Sep 23 13:43:16 2019
±----------------------------------------------------------------------------+
| NVIDIA-SMI 430.40 Driver Version: 430.40 CUDA Version: 10.1 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 108… Off | 00000000:03:00.0 On | N/A |
| 29% 33C P0 56W / 250W | 129MiB / 11177MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1345 G /usr/lib/xorg/Xorg 14MiB |
| 0 1864 G /usr/lib/xorg/Xorg 112MiB |
±----------------------------------------------------------------------------+

$ glxinfo |grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: llvmpipe (LLVM 8.0, 256 bits)
GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
GL_MESA_ycbcr_texture, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fog_distance,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

$ sudo lshw -c video
*-display
description: VGA compatible controller
product: GP102 [GeForce GTX 1080 Ti]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:03:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:60 memory:fa000000-faffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff

And in system setting->details->about, the graphcs item shows “llvmpipe (LLVM 8.0, 256 bits)”

The nvidia bug report file is also attached.
https://github.com/cbtogu/nvidiabugreport/blob/master/nvidia-bug-report.log.gz

Thanks.
nvidia-bug-report.log.gz (1.13 MB)

You used the .run installer with --no-opengl-files option to install the driver, this is expected then. Please uninstall it using the --uninstall option, then install the driver using Ubuntu’s software&drivers application.

Thanks for your quick reply. But do you mean install the driver using Ubuntu’s Software & updates application?

Yes, Software&Updates. I don’t use Ubuntu so I always forget how it’s called.

but usually we run the .run installer in the terminal, I’ve never installed the .run file in the Software & Updates application before. Please tell me how to do it. Thank you.

Hi generix, I know how to do it, and now the problem solved.
Thank you.

http://tipsonubuntu.com/2018/01/31/install-nvidia-390-25-ubuntu-17-10-18-04/

Now I know it, Thanks genrix.

Hi, I have got a similar problem and have tried solutions both in this post and some other related posts. Unfortunately, my problem is not solved.

My laptop has a Win10-Ubuntu 18.04 dual system. It has got an Intel integrated graphics card and a Quadro T2000. The default graphics, since installation of Ubuntu, is llvmpipe (“system setting”->“details”->“about”). I later installed 440.82 driver via Software & Updates. However, the system still uses llvmpipe. Rebooting the system does not help.

Following are some console outputs.

$ nvidia-smi
Fri Apr 10 17:59:06 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82 Driver Version: 440.82 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 Quadro T2000 Off | 00000000:01:00.0 Off | N/A |
| N/A 46C P0 7W / N/A | 0MiB / 3911MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

===============================================================================================

$ glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: llvmpipe (LLVM 9.0, 256 bits)
GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
GL_MESA_ycbcr_texture, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fog_distance,
GL_MESA_shader_integer_functions, GL_NV_conditional_render,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

===============================================================================================

$ sudo lshw -c video
*-display
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:16 memory:cd000000-cdffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:3000(size=128) memory:ce080000-ce0fffff
*-display UNCLAIMED
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: latency=0
resources: iomemory:600-5ff iomemory:400-3ff memory:6040000000-6040ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff

===============================================================================================

$ nvidia-settings

ERROR: Unable to load info from any available system

(nvidia-settings:6601): GLib-GObject-CRITICAL **: 18:31:55.911: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 18:31:55.914: PRIME: No offloading required. Abort
** Message: 18:31:55.914: PRIME: is it supported? no

===============================================================================================

The bug report is attached at

Some additional info:

  • I have removed /etc/X11/xorg.conf, since with this file, the login freezes after installing the Nvidia driver.

  • I have disabled secure boot. also disabled nouveau (“lsmod |grep nouveau” now gives no output).

  • Running “cat /etc/X11/default-display-manager” gives “/usr/sbin/gdm3”

Can anyone give some hints on what could be the problem? Thanks!

Please remove the “nomodeset” kernel parameter, it kills the intel igpu which is necessary on hybrid graphics (Optimus) systems.
Furthermore, make sure nvidia-prime is installed (sudo apt install nvidia-prime)
and switch to nvidia (sudo prime-select nvidia)
Then reboot.

Thank you! Just removed “nomodest” from “/etc/default/grub”. Also checked that the nvidia-prime was installed. Using “prime-select nvidia” shows “Info: the nvidia profile is already set”.

However, nvidia-settings still gives the same output, i.e.,

$ nvidia-settings

ERROR: Unable to load info from any available system

(nvidia-settings:4339): GLib-GObject-CRITICAL **: 18:53:12.037: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 18:53:12.039: PRIME: No offloading required. Abort
** Message: 18:53:12.039: PRIME: is it supported? no

Besides, the default graphics is still llvmpipe. Do you know what might be the problem?

Did you run update-grub after removing the parameter?
please create a new nvidia-bug-report.log.

1 Like

Oh my bad! I didn’t run update-grub. After running it, the GPU works now. Thank you very much!