Nvidia Geforce GTX 1650 driver isn't working in Ubuntu 18.04 (Default its using llvmpipe))

Nvidia Geforce GTX 1650 driver isn’t working in Ubuntu 18.04 (Default its using llvmpipe))
I have tried to install 440 and 435 properatory and opensource Nvidia drivers and tried to Upgrade kernel above 5.4 but no success Nvidia driver isnt getting loaded
It always show llvmpipe in Ubuntu about menu, I have attached nvidia-bug-report.log
please help me get rid of this issue .nvidia-bug-report.log (868.8 KB)

Please upgrade the HWE stack to latest:
sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04
and install the 440 driver
sudo apt install nvidia-driver-440
on reboot, please make sure on grub menu you’re booting into the current 5.3 kernel. Afterwards, create a new nvidia-bug-report.log.

Thanks a lot for your reply,
I have done all the above steps but after booting from 5.3 kernel system is now stuck at a Blank screen with the blue line


find attached image.

Please check if you can switch to VT using ctrl+alt+f1…f4
If not, please boot to recovery from grub and create a nvidia-bug-report.log.

I am not able to switch to VT using ctrl+alt+f1 to f4 and also tried to boot from recovery mode of 5.3 kernel from grub but could not able to do it
Finally i tried to log in with kernel 4.15 and generate nvidia-bun-report.log please find attachment.
nvidia-bug-report.log (588.8 KB)
I hope this log would help you.

Please try to boot into the 5.3 kernel again but add
to kernel commandline.

I am able to get login screen by adding nouveau.modeset=0 to kernel commandline
But after login it have same llvmpipe driver installed , i am not finding nvidia GTX 1650

One more thing to note i am using Windows 10 and Ubuntu 18.04 (dual-boot in ssd) , is this causing issue for nvidia video driver to get installed in Ubuntu?

nvidia-bug-report.log (769.1 KB)

find attached log by login to 5.3 kernel using nouveau.modeset=0

Driver mismatch:

[    5.921485] NVRM: API mismatch: the client has the version 440.59, but
               NVRM: this kernel module has the version 435.21.  Please
               NVRM: make sure that this kernel module and all NVIDIA driver
               NVRM: components have the same version.

Please run inside an empty directory:
sudo apt remove nvidia*
sudo update-initramfs -u
sudo apt install nvidia-driver-440
then reboot and post the output of
dkms status

I did and got output as nvidia, 440.59, 5.3.0-53-generic, x86_64: installed
by dkms status

Please create a new nvidia-bug-report.log

Log : nvidia-bug-report.log (1.2 MB)

Looks fully functional again, any issues left?

Please find attached image below where iam not finding Nvidia graphics it is still llvmpipe

And I want to run UnrealEngine when i launch it, It alsways give an error “Cannot find a compatible Vulkan device and driver, Try updating video driver to a more recent version and make sure your video card supports Vulkan”

Looking at this:

xrandr --verbose:

Screen 0: minimum 640 x 480, current 1600 x 900, maximum 16384 x 16384
nxoutput0 connected primary 1600x900+0+0 (0x2e) normal (normal) 406mm x 229mm

tells me you’re connecting over NX. That’s no real XDisplay. The real Xserver run fine on the Nvidia GPU with HW GL.

Hey its working as you said I was connecting through NX but its not real XDisplay , When i checked on the system the Nvidia graphics card driver got installed .

Thank you so much for you valuable help, Worked like charm.