Llvmpipe graphics, not able to use nvidia gtx 1650 gpu. Many errors while trying fix

I have lenovo ideapad gaming 3, I require the use of ubuntu 18.04 to use ROS Melodic. I finally got past the black screen and hang at uid 121, into the ubuntu gui by changing quiet splash to nomodeset, and blacklisting nouveau. When I enter ‘about’ I find that the graphics is shown as llvmpipe. Through reading the threads here, I have found that this is possibly because the laptop has two graphics: AMD radeon graphics and Nvidia GTX 1650. The solution shown here is as follows:

Q1: Is this correct?
Q2: What kernel should I upgrade to? Are there downsides to using the latest kernels with ubuntu 18.04 which is packaged with 5.4 something?
Q3: What firmware to download?
Q4: Instead of all this, is there any way to disable the amd gpu. I honestly don’t require it for my usage. If that gets disabled, wouldn’t the whole problem of a hybrid gpu go away? If so, how do I disable the amd gpu?

I upgraded kernel to 5.10.1-05001-generic, and copied all the renoir firmware files into /lib/firmware/amdgpu.
I get the following error when I run

sudo update-initramfs -u

So, I went on to try to fix these errors by doing the following :

sudo apt-get update &&
sudo apt-get -y install make gcc linux-headers-$(uname -r) build-essential git &&
git clone https://github.com/lwfinger/rtw88.git &&
cd rtw88/ &&
make &&
sudo make install &&
sudo reboot

But when I ran make, I got the following errors:

Well, that’s where i’m stuck now.
I have additional problems like brightness and nvidia x server gui not booting, and all of this points to the gpu not being detected/working. I’d really appreciate some help or direction with this.