Lenovo IdeaPad 3 Ubuntu 18.04, GTX1650 Ti not running, only llvmpipe

I have a Lenovo IdeaPad3 with Nvidia GTX1650 Ti, AMD® Ryzen 5 4600h with radeon graphics × 12 and integrated AMD Radeon GPU.
I am not able to get my Nvidia GPU running on Ubuntu 18.04. However, this setup work fine with Windows 10.

  • Software&Updates → additional driver only finds NVIDIA Corporation: Unknown, but says nvidia-driver-460 is installed (I already tried to remove and reinstall)
  • nvidia-smi: NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
  • playing around with prime-select did not help.
  • tried different approaches from this forum
  • Settings → About: Graphics: llvmpipe (LLVM 10.0.0, 128 bits)
    (e.g. nvidia-xconfig doesnt do what i want it to, nor does nvidia-settings - #7 by generix)
  • Currently I am running the laptop with prime-select intel, as this is the only way to get the laptop to boot.

Find the bug report attached:
nvidia-bug-report.log.gz (162.3 KB)

Any ideas how to get this setup running?
Thanks!

The kernel provided with 18.04 is too old to support your amd gpu, furthermore, support for amd+nvidia hybrid graphics was only introduced with 20.04.
If you really, really, really can’t go without 18.04, please see this thread to full end:
https://forums.developer.nvidia.com/t/nvidia-gtx-1650-lenovo-ideapad-3-ryzen-4600h-ubuntu-18-04-hdmi-screen-not-detected/161703

First of all, thanks for the quick reply.
Would it help to switch to the variant of this Laptop with Intel instead of AMD (IdeaPad Gaming 3i (15") | Leistungsstarkes 39,6 cm (15,6") Gaming-Notebook | Lenovo Deutschland)?
Is the 18.04 kernel supporting this setup?

The intel igpu should be supported by the 18.04 provided 5.4 kernel. Though it would also run better with 20.04 (render offload+runtime pm).