Ubuntu 18.04 nvidia-smi detected but not using graphics

Hi, I’m using rtx 3070 (notebooks) on ubuntu 18.04.
I’m using nvidia-470 driver and I can see my graphics by nvidia-smi
However, settings say graphics is llvmpipe (LLVM 10.0.0, 256 bits) and also, if I run the simulator, it does not use rtx 3070.
Could you help me? I attatched nvidia-smi

Well you are using a very new laptop and the newest driver on a quite old OS.
I suggest you install at least Ubuntu 20…
If that is not an option, post more info:
Laptop model, internal GPU (intel/amd), kernel version.
And run nvidia-bug-report.sh as root and post the resulting file here.

I have a similar problem. In my case, I’ve spent several days installing all the drivers and cuda toolkt and setup everything to work fine. But after I rebooted the laptop, the nvidia-smi shows no processes using the NVIDIA GPU, the simulator I use and the XServer also don’t use the NVIDIA.


nvidia-bug-report.log.gz (4.8 MB)

@marco.c.simoes
First purge bbswitch!
sudo apt purge bbswitch-dkms

Guessing you want PRIME display offloading…(Chapter 33. Offloading Graphics Display with RandR 1.4):
sudo prime-select nvidia
sudo update-initramfs -u
Reboot.
Then disable secure boot in the BIOS.

Thanks for replying.
My labtop model is Aorus 15p XD.
“lspci | grep VGA” command shows
compatible controller: Intel Corporation Device 9a60 (rev 01)
compatible controller: NVIDIA Corporation Device 249d (rev a1)
and system information of graphics says llvmpipe (LLVM 10.0.0, 256 bits).
kernel version of ubuntu 18.04 is 5.4.0-87-generic.
I attached nvidia-bug-report.sh.
Also, I tried ubuntu 20.04 and graphics worked properly. However, I should use 18.04 because 20.04 has some problems of compatibility.
Thankyou for your helpnvidia-bug-report.log.gz (332.9 KB)

@danny384

looking at dmesg, it’s all there:

[ 3.035210] [drm] Your graphics device 9a60 is not properly supported by the driver in this
kernel version. To force driver probe anyway, use i915.force_probe=9a60
module parameter or CONFIG_DRM_I915_FORCE_PROBE=9a60 configuration option,
or (recommended) check for kernel updates.

Use a newer kernel, which supports your integrated GPU.