Ubuntu 18.04 uses llvmpipe instead of GeForce MX230 after installing drivers

Hi everyone,

I bought a new Dell Inspiron 15 5000 with Nvidia GeForce MX230 GPU.
I have a clean Ubuntu 18.04 installation (dual boot with secure boot disabled and SATA changed to AHCI), where I did the following:

(1) add “acpi_backlight=vendor” to /etc/default/grub.
(2) connect to wifi
(3) install the nvidia-435 drivers in Software & Updates
(4) reboot

Upon running nvidia-smi, I get

Mon Dec 9 13:05:14 2019
| NVIDIA-SMI 435.21 Driver Version: 435.21 CUDA Version: 10.1 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce MX230 Off | 00000000:01:00.0 Off | N/A |
| N/A 50C P0 N/A / N/A | 0MiB / 4042MiB | 0% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| No running processes found |

Upon running prime-select query, I get


Upon running nvidia-settings, I get

ERROR: Error querying enabled displays on GPU 0 (Missing Extension).
ERROR: Error querying connected displays on GPU 0 (Missing Extension).

** Message: 13:07:06.476: PRIME: No offloading required. Abort
** Message: 13:07:06.476: PRIME: is it supported? no

ERROR: nvidia-settings could not find the registry key file. This file should
have been installed along with this driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The
application profiles will continue to work, but values cannot be
prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.

If I run nvidia-xconfig, a conf file is created in /etc/X11, but my laptop hangs upon rebooting. So, after experiencing this for about 5 times, I don’t try this anymore.

From Settings > Details, it is clear the my computer keeps on using llvmpipe.

As a side note, my laptop experiences extra troubles such as non-working brightness controls, not being able to wake up after hibernation and not showing the gear icon on the login screen.

I have been trying to solve these problems for three days, so please somebody, help me :) I’m pretty desperate at the moment.

nvidia-bug-report.log (2.36 MB)

Please see this:

Omg, thank you so much. It worked!