Ubuntu 20.04 using llvmpipe rather than Nvidia Driver


I’m currently having issues with getting my Ubuntu system to properly using Nvidia instead of the llvmpipe. Details below:

GPU: GeForce GT 710
Nvidia Driver Version: 460
Linux: 20.04.3

The system recognizes that the GPU is installed (shows up with lshw), but, the following commands show that it is not being recognized for some reason:

nvidia-settings outputs ‘ERROR: Unable to load info from any available system.’
nvidia-smi outputs ‘No devices were found.’
If I use prime-select nvnidia it says that the nvidia profile is already set.
Attempting to launch the NVIDIA X Server Settings app simply creates a blank window.

Safe booting is disabled in BIOS. I have already attempted to uninstall/reinstall Nvidia and have tried versions 470, 460, 450, and 390, and get similar issues with all of them. I have also tried reseating the GPU. Bug report is attached, but please let me know if any other information would be useful for debugging. Any help is appreciated; I’m out of ideas for this.

nvidia-bug-report.log.gz (174.7 KB)

[    0.385625] pci 0000:41:00.0: can't claim BAR 1 [mem 0x98000000-0x9fffffff 64bit pref]: no compatible bridge window
[    0.405499] pci 0000:41:00.0: BAR 1: no space for [mem size 0x08000000 64bit pref]
[    0.405501] pci 0000:41:00.0: BAR 1: trying firmware assignment [mem 0x98000000-0x9fffffff 64bit pref]
[    0.405503] pci 0000:41:00.0: BAR 1: [mem 0x98000000-0x9fffffff 64bit pref] conflicts with PCI Bus 0000:40 [mem 0x9c000000-0xa95fffff window]
[    0.405505] pci 0000:41:00.0: BAR 1: failed to assign [mem size 0x08000000 64bit pref]
[   30.400384] NVRM: GPU 0000:41:00.0: RmInitAdapter failed! (0x26:0xffff:1290)
[   30.400457] NVRM: GPU 0000:41:00.0: rm_init_adapter failed, device minor number 0

Please try

  • kernel parameter pci=realloc
  • using a different pcie slot
  • enabling above 4G decoding/large/64bit BARs in bios
  • upgrading bios
1 Like

Using a different slot did it! Thanks so much!