Default graphics card of Ubuntu 18.04.5 LTS shows llvmpipe (LLVM 10.0.0, 128 bits) instead of dedicated GPU (AMD/Nvidea combo). How to fix this issue?

I recently purchased a ASUS TUF Gaming A15 laptop with AMD-Ryzen 4800H (8-core) CPU. It has the Nvida Geforce GTX 1650TI as the dedicated GPU integrated with AMD Radeon as the default GPU. Upon dual booting the Windows 10 system with Ubuntu 18.04.5 LTS, I found that neither the default AMD GPU nor the dedicated Nvidia GPU were detected by the system. The system info instead showed llvmpipe (LLVM 10.0.0, 128 bits) as the default graphics renderer. Due to this, I’m not able to adjust the screen brightness and the battery seems to be draining fast while using Ubuntu.

My kernel version is 5.4.0-52-generic and I have secure-boot disabled in my BIOS.

Some useful info that I could gather from my terminal are as shown below:

Input: inxi -G
Output:

 Graphics:  Card-1: NVIDIA Device 1f95
            Card-2: Advanced Micro Devices [AMD/ATI] Device 1636
            Display Server: x11 (X.Org 1.20.8 )
            drivers: fbdev,ati (unloaded: modesetting,vesa,radeon)
            Resolution: 1920x1080@77.00hz
            OpenGL: renderer: llvmpipe (LLVM 10.0.0, 128 bits) version: 3.3 Mesa 20.0.8

Input: lspci -nnk | grep -iA2 VGA
Output:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1f95] (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device [1043:16df]
    Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
--
05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:1636] (rev c6)
    Subsystem: ASUSTeK Computer Inc. Device [1043:16df]
    Kernel modules: amdgpu

Input: dmesg | grep drm

Ouput:

[   15.975252] [drm] amdgpu kernel modesetting enabled.
[   15.976121] [drm] This hardware requires experimental hardware support.

I have the nvidea-driver-455 installed but it doesn’t get detected/loaded.

Input: nvidea-smi
Output:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

My /etc/default/grub/ initially had the following line initially.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=Linux i915.preliminary_hw_support=1 idle=nomwait acpi_backlight=vendor"

Changing the above line as shown below didn’t work either.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.cik_support=0 radeon.si_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.dc=1 amdgpu.dpm=1"

I have also tried the fix suggested in the following thread:
https://forums.developer.nvidia.com/t/nvidia-xconfig-doesnt-do-what-i-want-it-to-nor-does-nvidia-settings/107883/2

However, the screen blacks out while booting. So, I had to revert by using the command sudo prime-select intel in the recovery mode.

Any kind of help to fix the issue would be deeply appreciated. Do let me know if I need to provide any further details needed to debug the issue.