Ubuntu 19.04 Quardro 3200 6 gig nvidia card, external 2nd monitor on msi laptop

I was referred to this forum as the appropriate place to figure out my problem. My laptop runs very unstable with Ubuntu 19.04 with the open source drivers. I switched to the nvidia drivers and now my laptop is solid as a rock. The only problem I am now having is getting my external monitor to work. When I run xrandr I get that the hdmi is disconnected whenever it is plugged in. As well I have changed over to light dm of which I found some people did to get the second monitor to work. Nothing is fixing this problem. Does anyone have any insight on how to allow my second monitor to work with the nvidia proprietary drivers. I am on the version 435 latest drivers.

nvidia-bug-report.log.gz (62.1 KB)
nvidia-bug-report.log.gz (62.6 KB)
nvidia-bug-report.log.gz (99.3 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.

Ok, I just attached my bug report.

Please follow this:

  • remove the .run installer driver using the --uninstall option
  • delete /etc/X11/xorg.conf
  • add the ubuntu graphics ppa https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
  • install the driver from there (sudo apt install nvidia-driver-435)
  • install nvidia-prime (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

This did not fix the issue. How do I file a report?

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post.

ok, I just posted a new log

Still no kernel driver installed. Please run
sudo apt install --reinstall nvidia-driver-435
sudo apt install --reinstall linux-headers-5.0.0-32-generic
and post the output of
dkms status
sudo dmesg |grep -i secure

allan@allan-WS63-8SK:/$ sudo dmesg |grep -i secure
[ 0.000000] secureboot: Secure boot enabled
[ 0.000000] Kernel is locked down from EFI secure boot; see man kernel_lockdown.7
[ 1.709382] sdhci: Secure Digital Host Controller Interface driver

why does nvidia not make this cleaner? Everyone and there dog runs a second external monitor on there laptop! Thanks so much for the help though, I really would like to use my external monitor. Linux is still quite frustrating though. Great core, difficult on drivers still.

Please disable secure boot in bios.
Also, please post the output of
dkms status

The problem is, you did too many things.
Installing the nvidia driver on ubuntu normally just is
boot to desktop, start Software & Updates, select nvidia driver, reboot.

allan@allan-WS63-8SK:~$ sudo dmesg |grep -i secure
[ 0.000000] secureboot: Secure boot could not be determined (mode 0)
[ 1.698566] sdhci: Secure Digital Host Controller Interface driver

so secure boot was disabled.

please post the output of
dkms status

allan@allan-WS63-8SK:~$ dkms status
nvidia, 435.21, 5.0.0-32-generic, x86_64: installed

Ok, driver is installed and should be able to load now.
Does it work now? Otherwise, please create and attach a new nvidia-bug-report.log.

No, the external monitor does not work. And yes you are right, The ubuntu installer did provide for a clean install of the driver without command line initially. I actually tried quite a few versions to test this problem. When I revert to the nouveau open source driver I get the second monitor so I know it will work. But when I get the nvidia driver in it does not work. No second monitor.

I will get a new bug report uploaded later on today. Thanks again for all the support.

Ok, I just uploaded a new bug report diagnostic.

Please delete /etc/X11/xorg.conf

wow man, you are amazing and a big help. I really appreciate it, my monitor is working and all is stable again. Thank you so much again.

I do hope this process gets cleaned up but man it feels good to have a stable system using the right driver!