External monitor issue on Ubuntu 22.04 (Jammy) using Nvidia 510 and 470 proprietary drivers

I’m not able to see my external monitors on Ubuntu 22.04 64-bit using the latest or second latest proprietary drivers. I dual boot with Windows 11 and the Windows OS with Nvidia drivers can see the drivers clearly. Only when I revert to Ubuntu Noveau drivers can I see the external monitors. Enabling/Disabling Secure Boot in BIOS has no impact. Nvidia RTX 3060 Mobile GPU. Running the two external monitors through a DisplayPort hub. Everything works fine with it in Windows 11.

1 Like

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Please see attached: nvidia-bug-report.log.gz (310.6 KB)

Just a heads up, I did a separate but related post on the Ubuntu forums b/c a USB-C DisplayPort 1.4 capable hub freezes Jammy if I were to remove and reinsert the hub into my laptop using the Noveau drivers. Windows 11 does a better job at handling this behavior and there’s no OS crash involved with the latest NVIDIA 512.xx drivers installed.

Another interesting note, with the NVIDIA 510 driver installed, if I replug the blank monitors via hub into my laptop, one of the monitors has an “Out Of Range” message.

Does it work if you switch to performance mode?
sudo prime-select nvidia

So that does have an impact to where if I now reinsert the USBC hub, both external monitors no longer fade to black (standby mode) but I’m still not getting any video signal. Ubuntu now sees the 2 external monitors in the OS display setting and it does appear the windows I have open are moving to another screen when I change the primary monitor, but still no signal from the monitors themselves.

Screenshot from 2022-05-12 15-56-53

Working solution: So if I set the resolution to the exact same on all 3 monitors, the external ones begin to properly display: (1920x1080 which is also my native laptop monitor resolution). From there I can readjust the monitors to their respective native resolutions. The settings will also remain persistent after a reboot but you need to replug the hub back into the USBC port after you login in order to get the external screens to reappear.

Does copying
help with the monitors working without un-/replug?

Not really. In my setup, the /var/lib/gdm3/.config/monitors.xml was initially missing.

Have you fixed this problem? I dont seen an update on this post but I am facing a similar issue where on the latest 515 driver my RTX2070 just switched off the second monitor and would not bring it back even if i go to displays and try to set the joined displays set up. It just doesnt want to use the second monitor anymore. So annoying

I am attaching also the bug report from my system

nvidia-bug-report.log.gz (173.1 KB)

I will try to restard the computer as there is no way right now to get the two screens back hoping it will get fixed.
Notice sometimes the problem is present when i start the computer, then eventually goes away if i restart. So unstable

Yea it’s definitely unstable. I found that adjusting the resolution on each external monitor would bring them back online but I believe you have to do this every reboot unless there’s a way to modify a config file and preset the working resolutions. I also forget if upgrading to the latest Ubuntu build also fixed the issue in the end but that’s what I remember doing.

New updates, drivers or new kernels and i get back to this problem. Can Nvidia provide any help to troubleshoot please?

1 Like

Dell Inc. Precision 7760
NVIDIA RTX Series (Notebooks): NVIDIA T1200 Laptop GPU

The following driver is, in theory, compatible.

Ubuntu updated the Linux kernel, and now I cannot display my two external monitors. I had this issue initially when I installed 22.04, but I was able to use one of the Nvidia drivers available to fix the problem. Now no available driver fixes the problem, and installing older drivers, which I think may have fixed the issue previously, yields no results.

have you managed to fix it eventually?

Could you please test with latest 545 released driver.
If issue persists, please enable debug mode in xorg.conf file and share nvidia bug report from repro state.
Also please confirm how are you connecting monitors with notebook, is it via HDMI / DP or any dongle/converter.