Unable to detect external monitors on Ubuntu 22.04.01

I’m on a Dell XPS Laptop connecting two external displays via a USB-C doc. I am extremely new to Linux and cannot get ubuntu to detect my external monitors. I have no issues on Windows 11 (dual boot) I’ve tried purging and re-installing Nvidia drivers and disabling secure boot, just need some help. thanks in advance!
nvidia-bug-report.log.gz (413.7 KB)

if you are using 515.76 drivers try downgrading

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

This is what I get when I run that…

I’ve tried all of these… no luck

Just run
sudo nvidia-bug-report.sh
without any options.

here it is
nvidia-bug-report.log.gz (413.7 KB)

The nvidia gpu has no outputs so fiddling with it won’t make it work. All your external outputs are connected to the intel igpu but all show disconnected.
What kind of cable and connector are you using?

I’m using a j5 create USB-c dual HDMI doc. it wasn’t connected when I ran the bug report, sorry I can attach another in a couple of hours

I looked that dock up, it doesn’t use the laptop’s outputs but is a DisplayLink device. You need to install the drivers for it.

installed the driver, still not working

this is what I get with lsusb after installing the DisplayLink driver

Ok, you can forget about that dock, at least for display output.
It’s not a DisplayLink device as I suspected from description but uses a “Magic Control Tech” chip as graphics which doesn’t have a linux driver. At least I couldn’t find any. So that dock is Windows/Mac only. Please uninstall the DisplayLink driver.

so should I just try to find a docking station that doesn’t use Magic Control Tech?

Yes, you should look for one that uses the Alt-DP mode over USB-C of your laptop.

1 Like

just went and picked up a new dock, works perfectly. I really appreciate your help, thank you so much

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.