Ubuntu 22.04 - don't see external monitor using dock station

Hi Guys,

I’ve searched over the forums, but I cannot find solution to my problem. I’m on Xubuntu 22.04 with latest upgrade, on Dell 5531 (MX550 graphics). I have nvidia drivers installed (version 515), I am connecting Dell TB16 (dock using USB-C and everything works (network, audio, etc) except for the monitor which is connected using display port. It says “no signal” on the external device and OS .doesn’t see it. Do you know what may be the problem? Attaching bug report, thanks in advance!

And btw, it works fine on older laptop with the same system (MX130 graphics).

nvidia-bug-report.log.gz (260.5 KB)

All your external outputs are connected to the intel igpu, the nvidia gpu seems to have none. The intel gpu doesn’t detect any monitors. Don’t know whether this is USB-C port dependent, if they’re display-enabled or not. Already tried using another port? Please also check for a bios update.

Just checked the specs, both USB-C ports support display port alternate mode.

Thanks for the quick reply. Sorry if this is stupid question, but do you mean the external outputs are physically connected to the intel igpu? So in this case it doesn’t make sense to use nvidia graphics? Should I switch to intel then?

Regarding second USB-C port - I tried and doesn’t work as well. I’m on newest firmware in the laptop. Appreciate your help!

The nvidia gpu is there for performance tasks, you can switch to on-demand mode so it doesn’t always draw power.
sudo prime-select on-demand.
And yes, all the external outputs are physically connected to the intel gpu.

Thanks for all the information. Still no success here, but I guess it’s not nvidia problem.

Did you already try to use a simple USB-C/DisplayPort adapter cable to check whether there’s some compatibility issue with the dock (firmware)?

Don’t have the cable available now, but will try with direct connection soon, thanks for trying to help. I don’t expect much, because direct connection from the laptop to the monitor using hdmi cable doesn’t work as well. Ubuntu is just disappointing me with basic problems after many years of using with no issues.

Worth a shot is also upgrading to latest kernel using the liquorix ppa to get an updated i915 driver.

Just tried that 2 hours ago or so… no change.

Then you can only try with an adapter cable and if that doesn’t work, you might want to install Windows to check for a hardware issue.