Ubuntu 22.04 Primary Laptop Monitor is Not Working

I was on 20.04, and both displays were working without any issues. But, ever since I upgraded to 22.04, only the external display is working, and the primary display is black with a non-blinking cursor. (It blinks initially but stays stable after the external display starts output).

I tried removing xorg.conf file and placing a blank xorg.conf file. This results in both of the displays not working.

If I change the prime-select to intel and primary display works and the external display doesn’t show any output.

I tried adding the intel device to xorg.conf but, it’s not working, as well.

Here’s lspci | grep "VGA":

00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630]
01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)

xrandr -q:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   3840x2160     29.97 +  29.97    25.00    23.98
   2560x1440     59.95
   1920x1080     60.00*   59.94    50.00    29.97    25.00    23.98
   1680x1050     59.95
   1600x1200     60.00
   1600x900      60.00
   1440x480      59.94
   1280x1024     75.02    60.02
   1280x800      59.81
   1280x720      60.00    59.94    50.00
   1024x768      75.03    60.00
   800x600       75.00    60.32
   720x576       50.00
   720x480       59.94
   640x480       75.00    59.94    59.93
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thanks for your response.

Please find the file attached.

nvidia-bug-report.log.gz (269.4 KB)

Please delete /etc/X11/xorg.conf

I tried that already. Removing the file causes no display on the external and a blank screen with a cursor on the primary display.

The intel driver is broken
i915: Unknown symbol i915bkpt_dependency_symbol (err -2)
Looks like a mismatch between kernel and module, though I don’t know how this could happen.
Please switch to the standard 5.15 kernel instead of the 5.17-oem you’re currently running.
sudo apt install --install-recommends linux-generic

Okay, back to 5.15 and I am getting a blank screen on both displays. Tried restoring xorg.conf file but the result is the same.

Please create a new nvidia-bug-report.log

Here’s another bug report.

nvidia-bug-report.log.gz (133.5 KB)

Is there anything I can do?

Please delete /etc/X11/xorg.conf
Please set kernel parameter
pci=noaer
because there’s something wrong with your ethernet controller, flooding the logs.
Right after reboot, please create a new nvidia-bug-report.log