Laptop unable to display on external monitors through usb type c hub on Ubuntu 21.1

Cannot display on external monitors, through usb type c hub (2 hdmi ports). When this computer is in Windows 10 mode (dual booted), there is no issue with this hub.
Additionally on ubuntu, a separate hdmi port works fine

the hub i am using:

i-tec USB-C HDMI

’nvidia-smi’ shows;

sudo lshw -c video shows:
*-display
description: VGA compatible controller
product: GA106M [GeForce RTX 3060 Mobile / Max-Q]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
logical name: /dev/fb0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=nvidia latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:fa0-f9f iomemory:fc0-fbf irq:109 memory:d0000000-d0ffffff memory:fa00000000-fbffffffff memory:fc00000000-fc01ffffff ioport:3000(size=128) memory:d1080000-d10fffff
*-display
description: VGA compatible controller
product: Cezanne
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:05:00.0
version: c5
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: driver=amdgpu latency=0
resources: iomemory:fc0-fbf iomemory:fc0-fbf irq:58 memory:fc10000000-fc1fffffff memory:fc20000000-fc201fffff ioport:1000(size=256) memory:d1500000-d157ffff

inxi -G
Graphics: Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia v: 470.86
Device-2: Advanced Micro Devices [AMD/ATI] Cezanne driver: amdgpu v: kernel
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
Device-4: Trust Full HD Webcam type: USB driver: snd-usb-audio,uvcvideo
Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati,modesetting,nouveau,nvidia unloaded: fbdev,vesa
resolution: 1920x1080~120Hz
OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.0-22-generic LLVM 12.0.1) v: 4.6 Mesa 21.2.2

lsmod | grep nvidia now shows;
nvidia_uvm 1048576 0
nvidia_drm 61440 2
nvidia_modeset 1200128 3 nvidia_drm
nvidia 35311616 90 nvidia_uvm,nvidia_modeset
drm_kms_helper 262144 3 evdi,amdgpu,nvidia_drm
drm 561152 19 gpu_sched,drm_kms_helper,evdi,nvidia,amdgpu,drm_ttm_helper,nvidia_drm,ttm

mokutil --sb-state
SecureBoot enabled

in /etc/X11/ is xorg.conf.d which is empty

**xrandr --listproviders shows;**

Provider 0: id: 0x54 cap: 0x9, Source Output, Sink Offload crtcs: 4 outputs: 1 associated providers: 5 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0
Provider 1: id: 0x266 cap: 0x2, Sink Output crtcs: 1 outputs: 1 associated providers: 1 name:modesetting
Provider 2: id: 0x244 cap: 0x2, Sink Output crtcs: 1 outputs: 1 associated providers: 1 name:modesetting
Provider 3: id: 0x222 cap: 0x2, Sink Output crtcs: 1 outputs: 1 associated providers: 1 name:modesetting
Provider 4: id: 0x200 cap: 0x2, Sink Output crtcs: 1 outputs: 1 associated providers: 1 name:modesetting
Provider 5: id: 0x1d7 cap: 0x2, Sink Output crtcs: 4 outputs: 3 associated providers: 1 name:NVIDIA-G0

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Report attached

Since there are also DisplayLink devices, I guess the hdmi on the hub is not connected to the nvidia gpu.

nvidia-bug-report.log.gz (375.0 KB)
I installed displaylink after the problem exist.
I was guided by this source.
https: //www.youtube.com/watch?v=u4uyv-ZV5WY
This unfortunately didn’t help.
I uninstalled display link ,
updated report log attached.

Ok, much cleaner. Which exact model is that itec hub?

Here is the exact product:

Looks like it’s an active DisplayPort Mutistream to dual HDMI converter. The displayport connector on the nvidia gpu shows “disconnected”, though. Unfortunately, the converter doesn’t seem to have a power led as the problem might also be it doesn’t get any power from the usb-c connector due some driver problem.
Does anything show up in dmesg when you unplug/replug it?

Yes, it showed up:

Please use powertop to check whether autosuspend is enabled for that device and disable it, if so.