Ubuntu 20/22.04 RTX 4090 Card not recognized

Dear Sir or Madam,

I have an AMD 7950X CPU, MSI MPG X670E Mainboard
with an RTX 4090 card and cannot make it work in Ubuntu 20.04 nor 22.04. The installation is a fresh install on a dual boot (W10). The display resolution is fixed to 1024x768, lshw -c video shows only nvidia and that nvidia drivers were in use, but not the card. As my final goal was to install CUDA, I also tried installing that, but this even made the problem worse. Originally, nvidia-smi showed no devices found. Nvidia X Server just showed an empty page. I have tried the following solutions:

  • change PRIME profile to nvidia
  • change to 525 metapackage (instead of open)
  • change to 525 with the latest .run driver (display completely went black)
  • purging nvidia, then reinstall
  • secureboot is turned off
  • installed CUDA 12.0
  • upgrade distribution from 20 to 22

Now, I can only use the nouveau driver, even the official 525 driver from the ubuntu repositories create a black screen.

Can you help me to install that card properly so I can use CUDA with it? Thanks in advance.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I did, but your forum would not let me upload it. I uploaded it here instead. nvidia bug report - JustPaste.it

It’s a bit hard to see what condition the system is in now. Intermittently, when you used the runfile, the modules were correctly built and loaded. Though I think the driver you used was too old for the 4090 so you got a black screen.
Currently, there are no nvidia modules installed anymore.
Please post the outputs of
dpkg -l |grep nvidia
dkms status
ls -l /usr/lib/x86_64-linux-gnu/libnvidia* /usr/lib/x86_64-linux-gnu/libcuda*

Thank you for helping me. I can reinstall the 525 metapackage driver from the repository; then go to recovery mode and try to run the bug report sh again, if you want. I can also reinstall Ubuntu 20.04 fully again, if you think that you can help me more efficiently that way. For your other request:

dpkg -l |grep nvidia
ii screen-resolution-extra 0.18.2 all Extension for the nvidia-settings control panel
dkms status
no output
ls -l /usr/lib/x86_64-linux-gnu/libnvidia*
cannot access ‘/usr/lib/x86_64-linux-gnu/libnvidia*’: No such file or directory
ls -l /usr/lib/x86_64-linux-gnu/libcuda*
cannot access ‘/usr/lib/x86_64-linux-gnu/libcuda*’: No such file or directory

So there’s currently nothing installed. Please install a 525 driver, then create a new nvidia-bug-report.log.

So, I rolled everything back, including the distribution (20.04 now). Now I am back to the (open) 525 driver and I can see the screen in the wrong resolution, all other problems stay the same. Here is the log (this time upload did work =) ):

nvidia-bug-report.log.gz (129.6 KB)

I’d like to add that (only) during the installation with a Live-USB, the resolution of the monitor 1920x1280 was in fact correct. Maybe that helps.

Also: The card works with CUDA on the W10 partition.

Thanks so much for taking your time to help me!

Wrong driver. Please use Software & Updates to switch to the non “-open” driver version.

Thank you for your help. I again changed to the non open 525 driver. It resulted in the GUI not starting at all, so I had to access the computer with the terminal. I created the bug report while not having a display and attached it here. Can you still help me to understand what the problem is here, please?

nvidia-bug-report.log.gz (333.9 KB)

The problem is actually not the nvidia gpu but your amd igpu. The kernel is too old to support the 7xxx ryzen gpu. Either use the liquorix ppa to install the latest kernel and maybe also update the amd firmware or disable the igpu in bios if possible.

Thanks for the support. I was very close to a Kernel update as suggested when I realized the mistake was clearly caused by me. However, I want to say thank you, as your last comment pointed me to my rookie mistake. In case there is somebody else having the same issue, I’d like to give the following advice:

Please check, whether the monitor is plugged into the nvidia card. As I was not fully aware that AMD now comes with an integrated GPU, I simply chose the first recognizable HDMI port to plug my monitor in. It turns out, that this was the port of my mainboard, and thus I simply needed to change to the nvidia HDMI port.

Thanks anyways for your patience!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.