Unable to load driver for RTX 3090 on Ubuntu 20.04

This is a Desktop machine with AMD 5900X so no second GPU. Nothing unusual about the setup of my system apart from the GPU being water cooled.
It has been working on Ubuntu for a couple of months until today the screen resolution became back to 1024*768 (4k monitor). The same issue happened twice before and I was able to get it back just by randomly searching online and doing random things. But not this time. I have both Ubuntu and Windows 11 installed, and Grub. The only change was that I got Windows 11 updated (not like major update, just small system automatic update). It still works perfectly fine on Windows as of now.
The Nvidia Driver is not working. Tried many solutions including:

sudo dkms remove nvidia/515.76 --all
sudo dkms install nvidia/515.76 -k $(uname -r)
sudo update-initramfs -u

sudo apt-get remove --purge ‘^nvidia-.
sudo apt-get remove --purge '^libnvidia-.

sudo apt-get remove --purge ‘^cuda-.*’
sudo apt autoremove
sudo ubuntu-drivers autoinstall

None of them works.

inxi -G
Graphics: Device-1: NVIDIA driver: nvidia v: 515.76
Display: x11 server: X. Org 1.20.13 driver: fbdev,nouveau unloaded: modesetting,vesa
resolution: 1024x768~76Hz
OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.2.6

Unable to determine the device handle for GPU 0000:0A:00.0: Not Found

Kernel is 5.4.0-131-generic

nvidia-bug-report.log.gz (144.7 KB)

Bump for visibility

Driver 515.76 is problematic for some of us. Downgrade to 515.65 or upgrade to 520.xx

This is finally resolved!

It is related to boot option.
Disabled CSM support for UEFI.
Disabled Secure Boot.
Reinstall with sudo apt install nvidia-driver-520
sudo prime-select nvidia

It boots with 4k resolution now, but the framerate is trash. And Nvidia driver is still not loading. sudo modprobe nvidia fails.

I then tried to remove all nvidia packages, use the .run file from Linux x64 (AMD64/EM64T) Display Driver | 515.65.01 | Linux 64-bit | NVIDIA.
It tells me that kernel header does not exist.
I might have done something crazy in kernel source. So my uname -r gives 5.4.0-131-generic.
Make sure there are linux-headers- and linux-headers-5.4.0-131-generic BOTH of them in /usr/src.
If not, do sudo apt install for BOTH of them. I’ve been using
sudo apt install linux-headers-uname -r
from every other posts. But that’s not enough.
After the .run file finishes, it auto reboots and everything is working fine!

Finally, I turned back on CSM support and secure boot. It still works.

Hi, I am currently trying to get mine working.

  1. What kernel are you using

  2. What are the contents of


I’m using 5.4.0-131-generic.
There is no /etc/modprobe.d/nvidia-graphics-drivers-kms.conf on my system.

cat /lib/modprobe.d/nvidia-kms.conf

# This file was generated by nvidia-prime
# Set value to 1 to enable modesetting
options nvidia-drm modeset=1
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.