Nvidia-driver on Ubuntu 20.04 (5.14.0): NVIDIA driver is not loaded


on Ubuntu 20.04, kernel 5.14.0-1034-oem I had nvidia-drivers running and had no issues. After upgrading or rebooting it was suddenly not working anymore. I have a Dell PC and an GeForce GTX 1660 SUPER.

$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
$ ubuntu-drivers devices

WARNING:root:_pkg_get_support nvidia-driver-510: package has invalid Support PBheader, cannot determine support level
WARNING:root:_pkg_get_support nvidia-driver-510-server: package has invalid Support PBheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd000021C4sv00001028sd00003796bc03sc00i00
vendor   : NVIDIA Corporation
model    : TU116 [GeForce GTX 1660 SUPER]
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-510 - distro non-free
driver   : nvidia-driver-470 - distro non-free recommended
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-510-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

== /sys/devices/pci0000:00/0000:00:1f.4 ==
modalias : pci:v00008086d000043A3sv00001028sd00000A52bc0Csc05i00
vendor   : Intel Corporation
driver   : oem-somerville-cubone-rkl-meta - third-party free

== /sys/devices/virtual/dmi/id ==
modalias : dmi:bvnDellInc.:bvr1.1.25:bd05/17/2021:br1.1:svnDellInc.:pnOptiPlex7090:pvr:rvnDellInc.:rn0P9XHK:rvrA00:cvnDellInc.:ct3:cvr:sku0A52:
driver   : oem-release - third-party free
driver   : oem-somerville-meta - third-party free

When starting, I have multiple messages which i googled but did not get further:

nvidia-gpu 000:01:00.3 i2c timeout error ffffffff
uci_cgg 0-0008: i2c_transfer failed -110
ucsi_ccg 0-0008: ucsi_ccg_init failed - -110
Failed to start NVIDIA Persistence Daemon.
usb 1-13.4: 2:1: cannot get freq at ep 0x1

Stuff i tried
I tried many different solutions but nothing worked:

Reinstalling all drivers → No effect

sudo apt purge *nvidia*
sudo apt purge '^nvidia-.*'
sudo apt purge '^libnvidia-.*'
sudo apt purge '^cuda-.*'
sudo apt-get install nvidia-driver-470
sudo reboot

Tried both driver-470 & driver-510

Switched off Secure Boot in Bios → No effect

Blacklisting modules → No effect

blacklist nvidiafb
blacklist nouveau

Switching to 5.10-oem Kernel → Led to not being able to boot anymore.

Prime selecting nvidia → No effect

sudo prime-select nvidia

Nvidia bug report
nvidia-bug-report.log.gz (562.7 KB)

I would be so glad if somebody could help me. I have no idea left what to do next.
Thanks for your help!

kernel 5.13.0-39-generic worked, 5.13.0-40-generic failed.
Please check if you still have -39 available in grub.
If that failes, the nvida gpu might be broken.

Hi generix,
thanks for your answer and help! Today I tried out another GPU (GTX 1060) which had the same issue.
My older kernel had the same issue and upgrading to Ubuntu 22.04 also didnt help.
I’m currently backing up my data to reinstall Ubuntu. Hope that this helps and that the Motherboard is not broken or something.