Nvidia-driver on Ubuntu 20.04 (5.14.0-1045-oem) not working after cuda

I used to have Nvidia drivers working fine before trying to install CUDA.
After I tried several Cuda versions 10.2/11/11.7 I can’t get my nvidia drivers working anymore.
I tried several driver versions but all fail with this message when I try nvidia-smi

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

please find attached my Nvidia bug report.

nvidia-bug-report.log.gz (260.6 KB)

System INFO

  • Linux naruto 5.14.0-1045-oem #51-Ubuntu SMP Mon Jul 4 06:41:22 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
apt list --installed | grep nvidia

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libnvidia-cfg1-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
libnvidia-common-470/unknown,now 470.129.06-0ubuntu1 all [installed,automatic]
libnvidia-compute-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
libnvidia-decode-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
libnvidia-encode-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
libnvidia-extra-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
libnvidia-fbc1-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
libnvidia-gl-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
libnvidia-ifr1-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
linux-objects-nvidia-470-5.15.0-41-generic/focal-updates,focal-security,now 5.15.0-41.44~20.04.1+1 amd64 [installed,automatic]
linux-signatures-nvidia-5.15.0-41-generic/focal-updates,focal-security,now 5.15.0-41.44~20.04.1+1 amd64 [installed,automatic]
nvidia-compute-utils-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
nvidia-dkms-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
nvidia-driver-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed]
nvidia-kernel-common-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
nvidia-kernel-source-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
nvidia-prime/focal-updates,focal-updates,now 0.8.16~ all [installed,automatic]
nvidia-settings/unknown,now 515.48.07-0ubuntu1 amd64 [installed,automatic]
nvidia-utils-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
xserver-xorg-video-nvidia-470/unknown,now 470.129.06-0ubuntu1 amd64 [installed,automatic]
OS: Ubuntu 20.04.4 LTS x86_64 
Host: Precision 5560 
Kernel: 5.14.0-1045-oem 
CPU: 11th Gen Intel i7-11850H (16) @ 4.800GHz 
GPU: Intel Device 9a60 
GPU: NVIDIA 01:00.0 NVIDIA Corporation Device 25b8

Secure boot is enabled and the driver is unsigned. Please disable secure boot.

Thank you it now works.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.