NVIDIA driver installed but not recognizable on Ubuntu


My device is an RTX 2070, I am having an issue where I receive the following message after using ubuntu-drivers devices:

WARNING:root:_pkg_get_support nvidia-driver-510-server: package has invalid Support PBheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001F14sv00001462sd000012B9bc03sc00i00

I also get the following for the recommended driver:

driver : nvidia-driver-510 - third-party non-free recommended

Upon installing this recommended driver and running nvidia-smi I get the following message:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I have tried many different installation methods over the last few days to get things working, but nothing I’ve seen so far has been able to. I am also working on a project and I can’t make any progress until I’m able to resolve this issue. Please, any help would be greatly appreciated.

Update: I’ve attached the bug report here.
nvidia-bug-report.log.gz (107.0 KB)

The driver seems to be installed fine, but it is not loading.
Please look for files that could blacklist the module loading and remove it.

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
Note an entry with blacklist nvidiafb is good and actually needed.

The dmesg output of your bug report is unusable, because apparmor DENIED messages filled the buffer. Please configure apparmor to get rid of those, reboot and recreate the bug report.

I’m also facing similar problem. I’ve 3090 and ubuntu 20.04. I upgraded to 5.17.3 and driver stopped working. I followed your solution to comment out nvidiafb from blacklist file but driver is still not loading. Any other solution to try?

Hello @sterlingaesir, Did you manage to fix this issue? If yes how did you do?

You could try installing the latest recommended driver, which tends to be a better tested version. How exactly did you install your driver?

Hello @luc2003 I used following commands:

sudo apt install --reinstall gcc
sudo apt-get --purge -y remove 'nvidia*’
sudo apt install nvidia-driver-510
sudo reboot

After trying literally everything that I could find online, I was able to fix it by uninstalling and reinstalling Ubuntu. I wish there was a more realistic solution for people, it’s honestly absolutely ridiculous that this problem even exists.

@sterlingaesir thanks for update. I’m not going to reinstall ubuntu, it’s too much for me. 20 years ago I was doing the same thing with linux as I’m doing now. This thing never works out of box. I had to upgrade ubuntu to fix Intel WiFi Issue and it seems it broke GPU now. I’m without WiFi and GPU.

I’m so frustrated with linux world and those people who write drivers. So much of time waste for nothing.

I hope someone will get a fix for this.

1 Like

My thoughts exactly. This is my first time using Linux/Ubuntu, and I’m completely put off now. I’ve never had to deal with such nonsense on any other OS that I’ve ever used. I really don’t understand how this could be a reliable platform.

1 Like

@sterlingaesir after 20 years when your hairs grow grey you will still be facing similar issues ;) Welcome to the wonderful world of *ix operating system. The only thing which works in *ix world is MacOS, it’s freaking flawless, 7 years on it and not a single time I had to mess with it.

1 Like