Best pipeline/libraries to use ISP and CUDA cores


I would like to capture an image, debayer it, postprocess it and then run TensorRT with the result.
My current plan is to use gstreamer to capture it, then opencv to postprocess TensorRT for the inference. That should use the ISP with gstreamer and the cuda cores with TensorRT. But is there a better option, with more hardware acceleration on the jetson nano?

The optimal solution is DeepStream SDK. Please check
NVIDIA Metropolis Documentation

You can install the package through SDKManager, and then start with deepstream-app by running the command:

/opt/nvidia/deepstream/deepstream-5.1/samples/configs/deepstream-app$ deepstream-app -c source8_1080p_dec_infer-resnet_tracker_tiled_display_fp16_nano.txt
1 Like

Thanks I will have a look into Deepstream SDK

When I try to execute

/opt/nvidia/deepstream/deepstream-5.1/sources/apps/sample_apps/deepstream-app$ sudo deepstream-app -c ../../../../samples/configs/deepstream-app/source8_1080p_dec_infer-resnet_tracker_tiled_display_fp16_nano.txt

I get the following error message:

** ERROR: <create_multi_source_bin:1320>: Failed to create element 'src_bin_muxer'
** ERROR: <create_multi_source_bin:1411>: create_multi_source_bin failed
** ERROR: <create_pipeline:1294>: create_pipeline failed
** ERROR: <main:636>: Failed to create pipeline
App run failed

Please try to go to the same folder and run the command. See if this works.

And may try without sudo.

1 Like

I tried:

/opt/nvidia/deepstream/deepstream-5.1/samples/configs/deepstream-app$ deepstream-app -c source8_1080p_dec_infer-resnet_tracker_tiled_display_fp16_nano.txt

I tried it with and without sudo and had the same result as mentioned above.

Please remove cache for a try:

$ rm .cache/gstreamer-1.0/registry.aarch64.bin

If it still does not work, would suggest do clean re-flash. The command should work by default.

1 Like

Ok thanks that helped.
I now only face the problem described in Is there a way to execute deepstream-test1 with X11 forwarding

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.