bizare compile error on a drive that I do not have. what is "D:/Bld/rel/gpgpu/toolkit/r2.0/compi

I was trying to install the CUDA 2.1 Beta drivers - but something failed. This resulted in a roll-back to the 2.0 setup.

But even this rollback did’nt work. At the moment the cudafe++.exe I suppose its a compiler crashes and VS wants to debug it - when I try to compile my cuda files. The errors are :


1>c:\cuda\include\common_functions.h(56): warning: dllexport/dllimport conflict with “clock”

1>C:\Programmer\Microsoft Visual Studio 8\VC\INCLUDE\time.h(176): here; dllimport/dllexport dropped

1>C:\Programmer\Microsoft Visual Studio 8\VC\INCLUDE\xutility(870): internal error: assertion failed at: “D:/Bld/rel/gpgpu/toolkit/r2.0/compiler/edg/EDG_3.9/src/lower_name.c”, line 4179


since the D drive on this machine is somesort of HP-recovery drive - I have no idea what that is… I’m curius to find out what caurses this error and how to fix it.


you’re currently using MSVC 8.0
updating to MSVC 8.0 service pack 1 will fix this problem

That would be strange… since compiling cudafiles worked just fine before I tried CUDA 2.1 beta… Does anyone have a way of doing a full install - more than just uninstall… is there dll’s or other stuff that CUDA or the SDK does not clean up when unstalling?


Thank you!

You were, ofcourse, right :)