Black login screen when nvidia v470.103.01 drivers are installed on fedora 36 fresh install

I have a problem of black login screen after installing the nvidia v470.103.01 driver.
The graphics card is a nvidia 680M GTX 2Go Vram.
I want to specify that by typing the password the session opens normally and I access the kde desktop.
The NVIDIA X server settings work and the graphics card is well recognized.

With the nvidia driver “nouveau” the login screen appears normally.
Tested with the 390 driver, the login screen appears well too.

Thanks for your help.
nvidia-bug-report.log.gz (78.3 KB)

Please try setting kernel parameter

the parameter is already in the kernel.
Ex: GRUB_CMDLINE_LINUX=“rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rhgb quiet”

Sorry, I missed that. Please try embedding the nvidia modules into the initrd so they load earlier.

No worries.
How to do it by integrating the nvidia modules in the initrd so that they load earlier?

Add nvidia, nvidia-drm, nvidia-modeset to dracut.conf, add_dracutmodules
then run sudo dracut -f

You might take a look at these:
Bug 2084006 - Blanks TTY with NVIDIA driver since f36 upgrade
Bug 2071209 - Laptop display is not turning on with simpledrm driver in kernel and Nvidia driver
The rollout of simpledrm in the F36 kernels is incompatible with the current Nvidia drivers. There is a new kernel (5.17.11-300.fc36.x86_64) in updates-testing that uses the presence of the Nvidia modeset kernel option to revert to efifb/vesafb as a workaround until the driver is updated.

1 Like

Today I updated the kernel to v5.17.11-300.fc36.x86_64. The problem seems to be fixed.
The login screen appears again.
Thanks for everything.