Black screen after resollution change

I have Quadro 1000M on Gentoo Linux with NVDIA drivers 310.19.

I use X.org option “IncludeImplicitMetaModes” and everytime when I try to change resolution to some non-native (other than 1920x1080) it results in a black screen.

Screenshot taken with a changed resolution and black screen looks fine, it has proper resolution and contains proper image.

I change resolutions with “xrandr -s”.

Do you have any ideas what could be wrong?

Thanks,
vojta

It’s possible that the EDID provided by your monitor is providing a resolution that’s getting chosen by IncludeImplicitMetaModes that the monitor can’t really handle. Can you please enable verbose mode logging with “sudo nvidia-xconfig --mode-debug”, restart the X server, and then generate an nvidia-bug-report.log.gz file by running “sudo nvidia-bug-report.sh”?

I have also tried external monitor via DisplayPort and it also does not work. However, everything works fine with drivers 295.75 or older (those before EDID and xrandr modifications was made).

Here is nvidia-bug-report without connected my external monitor. Do you also want one with old drivers, which works fine?

EDIT: The forum does not allow me to upload bug report, it says “File has an invalid extension, it should be one of jpg, jpeg, gif, tif, tiff, png, bmp, jps.”. Feel free to download it from http://drbohlav.org/nvidia-bug-report.log.gz.

It looks like the EDID for the monitor is advertising that it supports various modes other than 1920x1080. The IncludeImplicitMetaModes functionality is choosing those other modes because it thinks the monitor can handle them. You can try disabling that functionality by adding this to xorg.conf:

Option "ModeValidation" "NoVesaModes,NoXServerModes"

Well, I am using

Option "ModeValidation" "AllowNonEdidModes"

. When I add options you’ve posted I have only one resolution in xrandr - 1920x1080. I am sure monitor can also handle other resolutions, because everything works just fine with older nvidia drivers (before 3xx).

I have the same problem. On Ubuntu 12.10, using the driver provided by ubuntu (304.43) I am forced to use the native resolution 1920x1200 (xrandr lists only that resolution). If I create an xorg.conf and write in “AllowNonEdidModes” as above, then xrandr gives me a longer list of options, but the screen simply shows black if I try to use any of them. No crashing/hanging, simply black display and it displays correctly again if I set the resolution back to 1920x1200 (typing xrandr command blind).

I have tried installing drivers 310.32 and 313.09; both have the same issue.

Other ubuntu users with the same problem: http://ubuntuforums.org/showthread.php?p=12474035
…and Fedora: http://forums.fedoraforum.org/showthread.php?t=285494

Bug report attached; I had to rename it with ‘.jpg’ to avoid the error mentioned above.

Update: If I run the command

xrandr --q1

(this forces use of xrandr 1.1 protocol) I can see a full list of resolutions available. Furthermore, I can use this to change the screen resolution. Unfortunately, the desktop environment requires use of xrandr1.2 in order to respond to resolution changes properly, so this is not actually a workable solution (the resolution changes, but the desktop does not resize; no applications are aware that resolution has changed). It is clear, though, that the nVidia driver is aware of these resolutions and is able to use them, but apparently is not correctly communicating them via the xrandr1.2 protocol.