Blender and new driver

Hi after update Windows driver to 537.58 Blender 3.6.1 don’t use anymore GPU i have Nvidia 4070 Laptop

Maybe the driver did not install correctly?
Double-check in GPU-Z → advanced tab → CUDA

1 Like

You are true GPU-Z show me this

But I reinstalled the Windows driver many times, but it didn’t change, I installed the latest one and a few versions a bit older
I also selected clean install, but nothing change

I also tried the “Display Driver Uninstaller (DDU) download version” utility
And after that I installed the latest Windows Nvidia driver 537.58 but no changes Cuda and PhysX and does not display checks in the boxes.

But why is OpenCL ticked? It depends on CUDA.
What do advanced->OpenCL and advanced->CUDA screens show?

This is what it show:

Now i try to install Cuda SDK 12.2.2 537.13
But it doesn’t work !!!

Did you probably install the “Microsoft OpenCL and OpenGL Compatibility Pack”?
If so, uninstall it.

The only thing I do with OpenCL is install Cygwin and compile a source that uses some packages in Cygwin for OpenCL but it didn’t find the GPU but only the CPU

I have not installed “Microsoft OpenCL… Pack”
This is Cygwin pakage:

This is OpenCL’s Cygwin package but this shouldn’t interfere with Windows drivers, I think

You may want to go back to the previous driver and try again with that. It might be a bug with the new driver. Let me know if that works.

Hi Richard, I have tried several times to install drivers older than 1 2 months, without success. But the normal driver works with DirectX or OpenGL but no cuda support.
Can you tell me the files that manage Cuda support on Windows 11, directories and .dll or .sys thanks, I’ll check that they are not blocked or damaged

“Hi Richard, I have tried several times to install drivers older than 1 2 months, without success”. - Why ? Without success ? What does that mean ? It failed to install ?. You need to go to Windows Device Manager and hard delete the GPU driver and force it back to Window Default GPU. Then force in any old driver. That is the only way you can go.

HI Richard, I did the test by removing every nvidia line in the “Programs and Features” of the control panel and they remove everything without problems. I installed the nvidia packages from scratch every time I changed the driver version by going back.
But the problem remained: installing the drivers but on z gpu it didn’t show the two Cuda and Physx boxes. I then started Blender to see if it gave the same message and never changed “Require Nvidia GPU with compute capability 3.0”

I’ll try your method today

Ps: I tried with these Nvidia packages: 537.58,535.98, 536.67

Yeah just hard kill the driver here

But honestly if that does not work, then it must be a Blender issue. Have you tried other software ? Does composer work fine ?

Does Blender work normally other than this ? You are not trying to use Cycles anyway right ? You are exporting the blender file into Composer. So does Composer render fine ?

I tried, then I restarted, but I think it put the previous drivers back when I restarted, in device manager I found the RTX 4070 Laptop again.

It’s not a problem with Blender in Z GPU doesn’t see the Cuda libraries, could it be a virus that prevents loading?
Yes Blender runs perfectly on cpu.

I have McAfee as my antivirus can be a problem ?

The laptop works fine I tried a game and it works but the Cuda is missing

Can you start Composer and see if you can render ?

Can you go here>>

Then post this

and this

Hi, my setting

it seem all working?

based on your most recent control panel snapshots, it looks like you have a proper install of the 537.58 driver, including (basic) CUDA support (NVCUDA.DLL - the CUDA driver API support, which comes with a GPU driver install). That is evidently not the same configuration as your GPU-Z output that shows the CUDA checkbox not selected (and driver version 535.98).

I’m not that familiar with blender, it may require a full CUDA toolkit install (it seems unlikely to me, but I don’t know.)

In any event, an additional step I would recommend for full clarity on the CUDA side, is a full CUDA install according to the windows installation guide, including the verification section. If you can build and run successfully sample projects such as bandwidthTest and vectorAdd, your CUDA install is working correctly, and from my perspective if there persists a problem with either GPU-Z or Blender, that problem is most likely on the 3rd party software, not your CUDA install.

Thanks Robert !

ok thanks, to confirm the driver is corrected installed, with basic support for Cuda.

I use Blender as testing because is frequently update and they have the support of all type of hardware, because the companys: Intel, Amd, Nvidia, Apple , give the information to the Blender developers to support the best thecnology is on the market, with the last library avalible for fast rendering and visualize, if i want to do a render with Cuda and Cpu i can :)

the second point with Blender i can switch fast between new or old version without install anythink, just take zip file and use it.
My problen often are use my works without any crash and if i developed one project 2 year ago i can use the right version of Blender.

Yes, Blender you can use with normal driver Installed, few moth ago after setting Laptop with windows 11 user account, i have download Blender 3.6.1 and at first run i selected GPU without problem.

in the end I also tried to install cuda sdk cuda_12.2.2_537.13
but no progress, z-gpu shows me the same thing and in Blender no gpu

Thanks everyone, when I have time I will try to solve the problem, I have some ideas but I don’t have too much time to try them.