Brand new boards, can't flash system.img

I have a couple of brand new Tegra TK1 boards purchased recently from Amazon. I download Jetpack L4T 2.3, which ran smoothly. I selected my network layout (I have the board plugged into the router via ethernet, as well as the host machine plugged into the router via ethernet). The board is confirmed in recovery mode using lsusb.

Once I begin the flash, it will start to send the system.img file, get to some arbitrary data value, then exit out with the following error message:

sending file: system.img
/ 314572800/2373112500 bytes sent data send failed NvError 0x8
command failed/warning: create failed
Failed flashing ardbeg.
0

Failed to flash device. Please check /<log location> for more details. Then press enter and try again.

When I press enter, it just hangs on “Determining IP address of target”.

This is happening to me for both of the boards I received. I also tried flashing the image directly from the command line with the same results.

Can anyone help me figure out what I might be doing wrong?

IP address and ethernet are never used during flash, this is only for post-flash packages. Is there anything special about your host, e.g., is it a VM?

There is nothing special about my host computer. It is just a dell tower running ubuntu 14.04 LTS. As I mentioned before, I have both the TK1 and the host computer plugged into the router via ethernet cables.

[EDIT] Sorry, I have replied before reading carefully your post.

The flash process uses USB, not ethernet (ethernet is used after).

You need to connect your jetson micro-usb to your host with a USB cable, put your jetson in recovery mode (press rec button for 5 seconds, press reset button for 2 seconds, only then release REC button).

Then from your host,

lsusb

should show something like:

lsusb 
...
<b>Bus 003 Device 007: ID 0955:7015 NVidia Corp.</b> 
...

Then you can start the flash pocess.

The 0x8 error code translates to:

0x00000008, "module is in invalid state to perform the requested operation"

I can see why @Honey_Patouceul is checking if the unit is in recovery mode. Are you sure the Jetson itself was in recovery mode before starting? Under lsusb the ID of a JTK1 shows as “0955:7140” (0955 is NVIDIA, 7140 is the TK1). If the Jetson is in recovery mode before starting, and this error still occurs, then there is probably a hardware issue.

Thank you all for your help!

I misinterpreted the “Network Layout” section of the JetPack installer. I thought it was asking me to plug the board into the router for some kind of automatic network configuration. When I unplugged the ethernet cable from the board and restarted the flash, everything worked. So apparently having the ethernet cable plugged in during flash will cause an invalid state error.

I appreciate the help in trouble shooting such a simple mistake.

FYI, you can run JetPack at any later date for additional package installs without flashing…this does require network layout to be set up. Flash itself will always ignore network.

hi all,

i have similar problem, it gets hanged while flashing the system.img file to JTK1 board.
pls refer the attached screen shot. I am using host as ubuntu 14.04 with virtual box.

VMs usually fail without extra effort, and are not officially supported. VMs can be made to work, see:
https://devtalk.nvidia.com/default/topic/1002081/jetson-tx2/jetpack-3-0-install-with-a-vm/

A VM’s USB tends to be a point of failure…it is the micro-B USB which handles flashing.

Thanks for your support,

The issue is resolved by installing the extension pack for VM which enables USB controller. The version of extension pack and Virtual Box should be same. In my case the version of virtual box and extension pack is 5.2.0. And changed the USB settings to USB 3.0.

The interesting thing about that is that the Jetson in flash operations is USB2. I’ve heard other people get things working by setting to USB3, but I think what is really going on is that a specific setting binding the Jetson to the port is what gets things working (a side effect of USB3 setup, and not the actual USB3 mode). Default USB behavior under a VM seems to fail part way into the flash nearly 100% of the time.